Windows 8 Mail app does not autocomplete email address from my Microsoft account contacts

Windows 8 Mail app does not autocomplete email addresses from my Microsoft account contacts. If I go into People app I can see all my contacts there and I can select "Send Email" option in a contact, which then opens the Mail app. But if I start a new email in the Mail app and type in a few characters it does not pull the possible email address from my contacts.

 

In the Settings->Accounts options for the Mail app I noticed that 'Content to Sync' has only got the option of Email and not Contacts. Screenshot link below. The option to remove account is greyed out.

 

http://i.imgur.com/kirMY9r.jpg

 

I tried uninstalling and reinstalling the Mail/Calendar/People app but still the same problem. Please help!

|
Hi,

I would suggest you to manually remove your account and sync it back.
 
a) Open the Mail app.
b) Press Windows Key + C, click on settings.
c) Click on Account, Click on your synced account.
d) Scroll down and Click on Remove Account.
 
You will be prompted again, click on Remove Account once again if asked.
After you have successful un-synced your account try to sync it back once more.

a) Open the Mail app.
b) Press Windows Key + C, click on settings.
c) Click on Account, Click on Add an account.
d) Follow the steps which will be prompted to you
 
Refer the following links.
 

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

The option to remove account is greyed out as this is the Microsoft account to log in to the computer. See the screenshot link in my original post.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi,

Did you run the Apps troubleshooter from What to do if you have problems with an app?

If yes what is the result after running the app troubleshooter?

I would suggest you to create new user account and check if the issue persists.

Create a user account

http://windows.microsoft.com/en-in/windows-8/create-user-account





Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Same problem - no Contacts used for autocomplete, and no '+' after the address field, so no way to use Contacts.  

I ran the Apps Troubleshooter, it reported that it fixed problems with permissions and missing/corrupted files, but the problem persists.   No other problems noticed on this system.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Same problem - no Contacts used for autocomplete, and no '+' after the address field, so no way to use Contacts.  

I ran the Apps Troubleshooter, it reported that it fixed problems with permissions and missing/corrupted files, but the problem persists.   No other problems noticed on this system.


I am having the same problem so just giving you a sanity check.

 

I also tried all of the aforementioned  resolutions as listed above but to no avail.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I think that at some point I actually got it partially working again - autocomplete came back, but still no '+' sign.   And I think the problem related to indexing on the C: drive.   I'd turned indexing off for the entire drive, to speed up Windows Explorer and avoid that crawling green progress bar when I browsed to a new folder or drive.  But I think the email app somehow depended on indexing, at least into my user folder tree.   I restored indexing and got auto-complete back.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Removing and re-adding the synced email account worked for me.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Does anyone else have another solution?  I removed and re-added my email account three times to no avail.  I have uninstalled and reinstalled Windows Mail with no success.  I tried the App Troubleshooter and it fixed some issues but I still cant get the autocomplete or the search function to work in the mail program.  I Have an email program I cant search and cant load an email address without going into the contacts folder which is a disaster in and of itself.  I have a clean install of Windows 8.1.  Losing patients with MS Windows and Office 365.  Have always been a fan of MS but am considering Apple because of this issue.  Either bring back Windows 7, give me a refund for Office 365 or give me a fix.  This shouldn't be a big issue.  An email program should just work.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated September 3, 2018 Views 2,114 Applies to: