Why is some language pack not available for display?

I just purchase a lanovo laptop for my father to replace the one recently broked. The new laptop come with windows 8 and I upgrade it to windows 8 pro, but when I want to change the display language to traditional chinese, it shows "language pack not available" I search online and it seems the traditional chinese language pack are only made available in some region, I just wonder what is the reason for this.
 

Question Info


Last updated June 16, 2019 Views 3,202 Applies to:
Answer
Answer

So this is how the issue was fixed for me:

 

First, if I’m not aware of your level so I’m explaining everything.

If you dont know what the Windows Key is – this is it http://en.wikipedia.org/wiki/Windows_key

In my steps I’ll use WIN to say press the Windows key, usually with another key so WIN+R is press the Windows key and the R key at the same time.

 

a)      Press WIN+R to bring up the Run box – type Regedit

b)      Click yes to open if you are prompted.

This opens the Registry – you have to be very careful working in here, its easy to mess something up. Get someone else if you are uncomfortable changing stuff here.

(seriously, changing something by accident can serious mess things up and you might not find what you changed – be warned.)

c)       For safety, we want to save the contents so that if we mess up we can go back to what we had

Therefore, click on the computer icon at the top, then in the toolbar click File / Export

d)      In the Export Registry File dialog, give the file a name & save it someplace like the desktop – you might want to find it again later.

e)      Then in the Registry, find the path HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate

f)       There should be one or two keys there

a.       WUServer

b.      WUStatusServer

>>> delete these 2 entries.

g)      Close the registry

h)      For Win8 press WIN to display all the tiles

i)        Right click anyway in the background to bring up a bar at the bottom of the screen and in the right corner some text “all apps” – click that to get even more tiles

j)        Under Windows System (its probably over to the right of all the tiles), find Command Prompt – right click & select Run As Administrator – select yes when prompted to open

k)      In the dos box type                                         Net stop wuauserv

l)        Once its finished we restart by typing     Net start wuauserv

m)    Give it a minute and then go into Control Panel as if you were going to add a language – it should give you the option to download the language pack or LIP now.

 

IF THESE STEPS DIDN’T WORK – go back to the reg file you created in step D – run that file to restore what you originally had.

 

Once again, this worked for me, I’m not saying it will 100% work for you but I hope it helps.

What you did was you deleted some sort of default entries that was messing with your ability to search and the language packs.

Removing them and then stop/start the service allowed your machine to search properly and find them.

 

 

9 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.