Taskbar does not show date

I have always had the Taskbar on left side of screen with the Taskbar properties set or “checked” to “Lock” and “Auto-hide” the Taskbar. (Windows 8 Pro)

 

The Taskbar now only shows the time and NOT the date.  A month ago it showed both the time and date.  That is what I like.  That is the default way it was out of the box.  Now, to see the date on Taskbar I have to click the clock.

I do not know why it changed to only show the time and not the date. 

 

I want to return it to the way the Taskbar was originally showing both the time and date.  How do I do that?

 

I have a i7 haswell midtower, 15GB memory, 2TB HD & Windows 8 Pro.

 

Thanks for the help

 

Question Info


Last updated September 20, 2019 Views 71,062 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 

Hi,

 

This could be because, you might have opted to have the small buttons on the Taskbar from its properties.  If you uncheck the option to have small buttons on the Taskbar, then that would increase the taskbar size and will display the date with the time on the notification area on the taskbar. You may follow these steps:

 

a)       Right click on the Taskbar and select “Properties”.

b)       On the “Taskbar” tab, uncheck the option “Use small Taskbar buttons”.

c)        Click on “Apply” and then “OK”.

d)       Now check if that display the date with the time on the notification area.

 

Hope this is helpful.

Regards,
Rajesh Govind - Microsoft Support Engineer

630 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Rajesh Govind, your suggestion of using larger tray icons to make the taskbar wider helped me to figure out how to fix this.  I went to taskbar properties, unchecked the “Lock the taskbar”.  Grab the edge of taskbar with mouse and pulled it wider by two millimeters and the date appeared.  I went back to taskbar properties, checked the “Lock the taskbar”.  Done.  Problem solved.

 

Thank you Rajesh Govind, I would not have thought of the solution without you. 

Now I need to figure out why the width of the taskbar changed when it was locked.  A very minor issue.  Not important.  I now know how to fix it if it happens again. 

Thanks for your help.

231 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 

Hi,

 

You are most welcome and thank you so much for replying with the results.

 

If you need any further assistance with Windows Operating System, please post your query on Microsoft Community Forums and we’ll be glad to assist you with it.

Regards,
Rajesh Govind - Microsoft Support Engineer

21 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

hi rajesh sir,

thank u so much its working.

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thank you so much! I am using Windows 10 Pro Build 10240 and almost 2 years from original answer this solution is still valid!

I checked and applied Use small Taskbar buttons; made sure the time and date at the notification area appeared, and then unchecked the same option (as I would like to have it).

Hopefully, someone from Windows 10 programmer team read this and would have fix this in the next build.

9 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The issue is still present even after unchecking the "Use small buttons". There is no date on the task bar any more. All I could do is to change the short time format that never allows you to show the date. Please find the details as shown below. I would have to Hover the calendar to see the short date I configured via Region and Language -> Additional Settings as you may already know.  

13 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I did this by experimenting how to show the date in the windows 10 taskbar, and this worked. I left the “use small taskbar buttons option in the taskbar settings unchecked.

Make sure the short and long date formats match in both windows:

The Region window: (Settings; Date and time; Additional date, time & regional settings; change date, time or number formats)

and the Change date and time formats: (Settings; Date and time)

18 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I think, Just resizing your taskbar will solve your problem, increase width.

Remember to uncheck: Lock the Taskbar (right click taskbar)

thanks good luck

  

22 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Mr. Rajesh your reply was dead on point, however Surface Pro (2017) do not have "properties" as an option to click on when you right click on the taskbar. You must click " Taskbar setting" then continue w/ the reply you gave. THANK YOU....IT DROVE ME CRAZY NOT TO SEE MY TIME/DATE. Hope this has helped.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I just figured out how to fix this, well at least show the date.

The short date must me "M/d/yyyy" not "M/d/yyyy dddd"

20 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.