Question

Q: Language setting question / Display lang. Input lang.

I have always used English Windows (for practicality reasons).

I live in Sweden, thus needs to have Swedish keyboard.

I am Korean, thus have the need to be able write Korean (Korean IME).

 

I am sure there are tons of ppl around the world using Windows with similar criteria...

 

For better or worse, Win8 seems to have a spell check function built-in that does the spell check depending on the language setting chosen.

I have noticed that this function also can be disabled in the setting.

 

My annoyance is that, when ever I change the input language, I have to do an additional momentum to jump over the ENG input (which I don't need).

In Swedish input mode, I can type Swedish.

In Korean IME input mode, I can type Korean & English.

 

It seems that the Win8 have somehow merged the Display and Keyboard language into one package.

It seems that I am stuck with English input because I have chosen the English Display language.

 

My question is, can I somehow, disable/hide the English input so I don't have to jump an extra step to come to the language input that I wish for...??!!

(now I have to jump from Swedish to English to Korean to come to Korean, etc. etc.)



After some struggle, I have found the solution to above problem.

As this is not a common situation (beginning to be, thou...) where display language is

not same as input language, furthermore with additional input language.

No one I asked knew the answer not understood the questions.

 

This is how I did it and works fine!;

 

  1. Go to 'Change your language preferences' and select your default language. (in my case English)
  2. In the Default language option, 'Input Method' add the language your keyboard is. (in my case Swedish)
  3. Remove the default input language. (in may case English - that was selected with I selected English as the Display language)
  4. Back to 'Change your language preferences' click 'Add a language'. (in may case Korean)

This way my Win 8 is displayed in English, default keyboard(input method) is Swedish, and I can type in Korean and English(Korean input method includes English)

 

If you are novice and needs more detailed steps, please let know !

 

Good luck!

Did this solve your problem?

Sorry this didn't help.


Are new metro apps English too? Try to logout from your system and log in once more. I had no luck in setting up pure English win8 with Japanese and Russian input methods. Old style win8 become English, but new style win8 is still in highest priority language.

It is really annoying, so for now settled with purely Japanese windows.

Did this solve your problem?

Sorry this didn't help.


Hi!

Can you please explain to me once again how you want it to be??

You want English as you display language, and to be able to input Japanese and Russian - is it correct??

Did this solve your problem?

Sorry this didn't help.


Ah, I read your answer one more time. If you can add keyboard layout of language you want to type into 'English' language, it does work. Then you can delete English keyboard layout and everything goes well. Here's superuser.com question about that http://superuser.com/questions/486753/how-to-set-start-screen-tiles-language-in-windows-8?lq=1 . Most Latin languages can be added to 'English' language. Same goes for Russian - you can add for example Ukrainian layout there and type in Ukrainian.
But you can't add Russian layout to English language.

There is Advanced settings submenu and you can specify Override for Windows display language. 
If language is not in this list then you need to install language pack for specified language.
For that 
1) Select "Use language list" in override selection box in advanced language options
2) Go to language list
3) Add language you want to install pack of
4) Go to options of that language
5) Install language pack of that language

Then you can remove that language from the list and select it as an override (you have pack installed). This sure does get most of windows in that language. As far as I understand, you get every non-store app excluding store itself in override language, but store apps are in language-list languages by list languages priority.
And the thing that the language of the system depends on selected input method really sucks.

Here's my superuser.com question on this topic.
http://superuser.com/questions/502658/complicated-input-language-and-display-language-setup-in-windows-8

Did this solve your problem?

Sorry this didn't help.


Are new metro apps English too? Try to logout from your system and log in once more. I had no luck in setting up pure English win8 with Japanese and Russian input methods. Old style win8 become English, but new style win8 is still in highest priority language.

It is really annoying, so for now settled with purely Japanese windows.

this is also a problem i have run into.

metro tiles/apps run in the language of the default INPUT keyboard rather than the DISPLAY language.
apparently the metro ui developers are unsure of the difference between INPUT and DISPLAY.

so i'm happy to stick with windows 7, i'll try again with windows 9 maybe.

Did this solve your problem?

Sorry this didn't help.


 
Question Info

Views: 692 Last updated: July 4, 2018 Applies to: