How to remove UAC shield icon overlay

Hello guys.
I have a problem and I want to ask you, because I can't find a solution. Problem is not a big deal, but it's very annoying. The problem is a blue and yellow shield on some icons. I know that the shield is showing that I'm running the program as an administrator, and that the shield is a part of UAC. In properties, nothing is ticked. I was thinking that 'RUN AS ADMINISTRATOR' field was ticked, but it wasn't. I really want to get rid of that annoying shield, so I thought that you guys maybe have a solution. Feel free to comment.
P.S. : Sorry if I had any grammar issues.
 

Question Info


Last updated May 31, 2020 Views 90,740 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hello guys.
I have a problem and I want to ask you, because I can't find a solution. Problem is not a big deal, but it's very annoying. The problem is a blue and yellow shield on some icons. I know that the shield is showing that I'm running the program as an administrator, and that the shield is a part of UAC. In properties, nothing is ticked. I was thinking that 'RUN AS ADMINISTRATOR' field was ticked, but it wasn't. I really want to get rid of that annoying shield, so I thought that you guys maybe have a solution. Feel free to comment.
P.S. : Sorry if I had any grammar issues.


Hi

 

That shield icon is a reminder that the file requires Administrator privileges to open.

 

It can save time for a user who does not have admin privileges.

 


Regards

MVP 1999 - Present
Windows Insider MVP

16 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thank you for your reply, but I only want to know how to remove that shield.

80 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi CicviTheGreat,

To make changes to the User Account Control Settings complete the following steps:

  1. Press the Windows key + C
  2. Select Search
  3. Type UAC
  4. Select Settings
  5. Select the UAC tile
  6. Use the slider to adjust the UAC settings

 

Dena

29 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thank you for your reply, but I have already tried that, it didn't help.

20 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi! I had this problem too.Windows couldn't solve it but when I turn the UAC off by TuneUp Utilities 2013 it solved and the blue and yellow shiels cleared from icons.Install TuneUp Utilities 2013 and go to CUSTOMIZE WINDOWS bar and then go to SECURITY.Turn off the UAC  and restar windows.Thats it!

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello guys.
I have a problem and I want to ask you, because I can't find a solution. Problem is not a big deal, but it's very annoying. The problem is a blue and yellow shield on some icons. I know that the shield is showing that I'm running the program as an administrator, and that the shield is a part of UAC. In properties, nothing is ticked. I was thinking that 'RUN AS ADMINISTRATOR' field was ticked, but it wasn't. I really want to get rid of that annoying shield, so I thought that you guys maybe have a solution. Feel free to comment.
P.S. : Sorry if I had any grammar issues.

I finally got rid of my yellow & blue UAC shields on my desktop shortcut icons.  First, note that the shields only indicate that the shortcut opens the application with “administrator privileges”.  Second, the shields only appear on the desktop shortcut icons and can not be removed by deleting the shortcut.  My problem was with Corel PaintShop Pro X6.  The program uses two desktop icons, one for 32 bit and another for 64 bit.  The shields covered the 32/64 bit indicators in the lower right hand corner.

1.       Uninstall the application that the shortcut relates to.

2.       Reinstall the application. 

3.      DO NOT take any actions to open the program using the desktop shortcut icon until you complete the next two steps.  You can do any updates, registration etc. later.

4.      Right click on the desktop shortcut icon and select “Properties”.  Select tab for “Compatibility”.

5.      On “Privilege Level” at the bottom of this window: remove check from the box next to “Run this program as an administrator”. 

 

23 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello guys.
I have a problem and I want to ask you, because I can't find a solution. Problem is not a big deal, but it's very annoying. The problem is a blue and yellow shield on some icons. I know that the shield is showing that I'm running the program as an administrator, and that the shield is a part of UAC. In properties, nothing is ticked. I was thinking that 'RUN AS ADMINISTRATOR' field was ticked, but it wasn't. I really want to get rid of that annoying shield, so I thought that you guys maybe have a solution. Feel free to comment.
P.S. : Sorry if I had any grammar issues.

I finally got rid of my yellow & blue UAC shields on my desktop shortcut icons.  First, note that the shields only indicate that the shortcut opens the application with “administrator privileges”.  Second, the shields only appear on the desktop shortcut icons and can not be removed by deleting the shortcut.  My problem was with Corel PaintShop Pro X6.  The program uses two desktop icons, one for 32 bit and another for 64 bit.  The shields covered the 32/64 bit indicators in the lower right hand corner.

1.       Uninstall the application that the shortcut relates to.

2.       Reinstall the application. 

3.      DO NOT take any actions to open the program using the desktop shortcut icon until you complete the next two steps.  You can do any updates, registration etc. later.

4.      Right click on the desktop shortcut icon and select “Properties”.  Select tab for “Compatibility”.

5.      On “Privilege Level” at the bottom of this window: remove check from the box next to “Run this program as an administrator”. 

So I'm using Windows 8.1 pro x64 and I have completely disabled UAC, but I still get an shield icon on top of a few icons.. 

I have restarted the computer and tried to do the above, but the box "run this program as an administrator" was not checked, but I still have the annoying shield on top of the icon.

So disablind UAC and restarting didn't work;

Uninstalling, installing again, unchecking the little box before running the app didn't worked too;

Any other possible solution?

Sckhar Leviathan

8 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Funny how such a stupid little icon can be so annoying.

1- Right-click the shortcut.

2- Click the Open File Location button.

3- Make a copy of the target file (e.g., WinRAR.exe -> WinRARcopy.exe)

4- Right-click the new copy.

5- Send to > Desktop (create shortcut)

6- Delete the original shortcut from the desktop.

7- Rename the new shortcut to suit.

259 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

If your issue is solved using the "make a copy of the target file" approach given by user HED12345, it might have been due to the Icon Cache.  I found another way to fix that situation which could be a little more robust.   It is here: trying-to-remove-unwarranted-uac-shield-overlay and I've pasted the solution by user Simon Said below.

Resetting the icon cache by deleting the IconCache.db file located under your local profile folder (%LOCALAPPDATA%) should do the trick.

  1. Kill the Explorer.exe process by clicking on Start button > Hold down Ctrl+Shift & Right Click on empty area in the Start Menu > Click "Exit Explorer".
  2. Click Ctrl+Shift+Esc keys and open Task Manager.
  3. Click File > New Task > cmd.exe > OK. This will open the command prompt.
  4. Type del /AH "%localappdata%\iconcache.db"
  5. Press [ENTER]
  6. Type explorer.exe
  7. Press [ENTER]

Sacramento, California

26 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

My exclusive solution is to use free nircmd.exe command-line utility to call the target application.

Get nircmd.exe from http://www.nirsoft.net/utils/nircmd.html and copy it into your C:\Windows folder.

Open property dialog for the shortcut you want to get rid of shield symbol. Click 'Change icon..' and confirm with 'OK' right away without any changes (just do this step!)

Add 'nircmd elevate ' at begin of the target application path.

For example:

nircmd elevate "C:\Program Files (x86)\Photoshop CS6\photoshop.exe"

Confirm with 'OK'. The shield symbol is gone. The admin privileges will remain for the target application due to 'nircmd elevate' command.

74 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.