Custom hotkeys to change input language disappear frequently

I had the same problem in Windows 7, and it persists in Windows 8. This happened in three computers I had, including the current one.

I have configured three input languages, and I assign a hotkey (alt+shift+number) to each of them. However, after some time, the hotkeys are reset; sometimes it's just some of them, other times they all disappear. They often keep working, but there are a few times when I can't switch languages in any other than pressing shift+alt or by clicking.

This issue may also be related - Sometimes I can't change languages from IME to English or any other. For that, I have to switch between input methods in IME (with alt+`), and only after I do that I can use the hotkeys. Again, switching languages with shift+alt works, but the custom hotkeys don't.

Does anyone know the cause of the problems I described? Is there a way to fix it? Are there any plans from Microsoft to fix these bugs?

Thank you.
|

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

I still have this problem, I will try to post here each month until the problem gets resolved. I will also write a post on my blog and share our experience there.

I tried the solutions mentioned above and still didn't solve the problem.
In between I also installed Windows 8.1 and the hotkeys "magically" appeared again for half an hour just to disapper by the next lock screen.
WIN-SPACE combination works, but its user experience sucks.

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I was experiencing this problem and it was driving me crazy - I was living in Ukraine and this issue was coming up constantly.  I realized the problem was only happening when I went to the Lock Screen.

The solution was to Copy my language settings to the lock screen.  Unfortunately, my notes are sparse but I still wanted to post for my fellow language lovers and polyglots:

1. Go to Control Panel -> Language -> Advanced Settings
2. Set up your Language Bar Hot Keys like you want
3. Click "Apply language settings to the welcome screen..."
4. Click Copy Settings and select Welcome Screen

Voila.  That should do the trick and you won't see this issue ever again.  Can someone else confirm this fixes the problem for them?

65 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Interesting solution... worth of trying. Thanks


I made changes so let's see what happens.


Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Amazing. Works like a charm. 

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Do confirm, by this time I've been checking this solution for more than 2 months and evrth works great. Unfortunately I have no time to write on this topic.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Seems to work for me - thanks for posting!

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Finally, after around two years ToroLuke has written a good solution.
Thank you very much!

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi
Thanks for this solution - I followed the 4 steps a couple of days ago and it's worked ever since.   The only thing which is a tiny bit strange is that you sometimes have to open up an app before you can switch the keyboard over (e.g. IE or Firefox and then you need to click on the address bar, or in Outlook open up a new or existing e-mail, before the hot keys work again.   But after you've done that, they continue to work in the inbox, too.   Not sure if that explanation is clear.)   Whatever, it really works!!
In any case cheers once again.   Just goes to show that Microsoft aren't interested in their customers - they wanted me to buy a $50 warranty before they'd look into the problem and try and solve it.   They gave me some story about different software packages being mutually incompatible, or said it was a virus...
Thanks!

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Yes, I confirm this solution posted by ToroLuke on January 29, 2014 ("Apply language settings to the welcome screen, system accounts and new user accounts" and then "Copy settings"). It has been working for me too. I have turned off and on my laptop about three to four times and my language settings are still there.

Thank you for posting and sharing this solution, ToroLuke. After almost two years there is finally a real solution and you found it. 

You are the man!


1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Yes, that's it, it fixed it.  Thank you very much. (Windows 8.1)

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated September 13, 2021 Views 17,268 Applies to: