Windows 7 Update Disabling Intel My WiFi Technology Adapter

I recently purchased a Vaio laptop for the WiDi capabilities.  Out of the box it worked as advertised, but after a round of various updates from Microsoft and Sony, the WiDi becomes disabled.  The message that appears is: My Intel WiFi Technology disabled, please restart your computer.  Another message that appears is: My Intel WiFi Technology: Adapter Not Found.  I've poured over all the vendor community postings (Intel, Netgear, Sony) regarding this issue but no one seems to have come up with a solution.  The only method for recovery is to do a complete system restore which puts everything back to factory settings.  Once I do that, it works for a little bit until the updates download again.  I've tried turning off the auto updates and I've ensured that all the latest drivers were installed (even after doing a complete system restore) but nothing seems to prevent the adapter from becoming disabled.  I don't have any issues with the WiFi, only the WiDi.  This issue seems to be affecting all brands with WiDi capabilities.  I'm not sure if it's affecting only Intel i5s or both i5s and i7s.  Any one have any other suggestions?

Question Info

Last updated October 6, 2019 Views 63,617 Applies to:
Thanks for the suggestion of rolling back the driver.  However, I found that once I opened the device manager, I was able to re-enable the device to work properly and it was unnecessary for me to actually roll the driver back.

19 people were helped by this reply


Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.