Is windows update not compatible with IE9!?Unable to install IE9 (Code 80072EFD)

original title: Is windows update not compatible with IE9!?  (WIN7 32bit)

I realised about a week ago that my Windows Update hadn't successfully CHECKED for updates since 2 Nov and have since been searching for a resolution to get the last two weeks of updates.  I have run hours of virus/malware/security checks to no avail... and today I tried something else.

Today, I read to uninstall Internet Explorer 9 -- I've been using FireFox as my default the last few months (as IE9 became slow and cumbersome) so, I went into installed updates and deleted IE9 and HEY PRESTO! Windows Update started working again as soon as I rebooted my system. 

Naturally this introduced other dramas - Microsoft Outlook would no longer work as there was no IE version remaining (Win7 didn't have IE8 to fall back on) so I needed to reinstall it.  I guessed: Now I have 2 weeks of further Windows Updates, whatever the problem was should be fixed now, right?

It was a drama in itself getting IE9 to re-install... it kept failing.  Research informed me to enter safe mode to reinstall, which worked a treat....

Only now Windows Update is back to its same error: "encountered an error trying to contact the server.  Please try again later [Code 80072EFD]"

So, I'm back to square one with no Windows Update, unrequired IE9 (needed only for Outlook requirements); Firefox active and a potential security breach at any moment, although I have two virus/malware scanners running.

I really hope someone can help me either with a fix for Windows Update for Windows 7 Home Premium; or a way of installing IE8 or any other program that can give Outlook what it needs without blocking Windows Update.


Question Info

Last updated October 29, 2019 Views 10,829 Applies to:

Now I have WU auto checking again!

I was offered 3 potential optoins

1) (yet another) virus scan - this time
Disable firewalls or other Internet browser programs that can affect the Internet Connention
Reset proxy (for LAN connection)

Feeling like I'd already exhausted 1 & 2 (and they would take more time) I skipped direct to Suggestion Three and found success.

In essence: Uncheck the "Auto Detect Proxy Settings" on the IE Connections Tab; but ALSO check the "Use A Proxy..." and access the advanced box - then delete any entries from there also.  Then UN-check that same option on your way out of the options menus.

There were also directions for Reseting the Proxy Cache using an elevated CMD prompt (with command = "netsh winhttp reset proxy" [without quotes]) - if this returns anything other than "Direct Access (no proxy)" then there's something other to investigate.

Hope this can help someone else in future - and thanks Imran and especially Jose for your attempts to assist - even though you didn't personally advise the solution you were part of the process that led me to a successful outcome, and I appreciate it.

12 people were helped by this reply


Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.