How do I stop Windows Update from restarting my computer in Windows 7 Home Premium?

While I do not mind Windows Update automatically updating my PC, hacing it force a reboot when I am logged in is causing a problem.  I currently have WU set to perform the updates at 3am, and when it finished, if there needs to be a reboot, I am not there to tell it to wait.  I would prefer to leave the time settings as they are, and simply disable the automatic reboot, instead opting for WU to let me know it needs to reboot the PC.  I found ways of doing this in XP and Vista, including registry edits and group policy modifications.  However, The registry is obviously slightly different so the keys do not exist compared to what I found, and since I am running Home Premium I do not have gpedit.

Where in the registry can I make a change so I don't have lost data when WU resets my computer at night?
 

Question Info


Last updated January 19, 2020 Views 77,089 Applies to:
Answer
Answer
Another way to do it without hacking the registry, which can be scary for some users), is to follow the instructions on the following website:

http://weblogs.asp.net/jgalloway/archive/2006/02/11/438009.aspx

I've pasted in the main parts of it, in case the link goes dead (but no nice pictures though):

  1. Go to Start -> Run(or in Vista and 7 simply press the windows orb)
  2. Type: gpedit.msc
  3. Expand Local Computer Policy / Computer Configuration / Administrative Templates / Windows Components / Windows Update
  4. Double-click "No auto-restart for scheduled Automatic Updates installations"
  5. Select "Enabled", then OK. Close the Group Policy configuration program.
That should stop it autorestarting.

27 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.