Error Code: 0x800B0100 - Can't install SP1

Win7pro SP1 won't install. I get 'Trust_E_NoSignature(0x800B0100). I've tried 'Troubleshoot problems installing a service pack for Windows 7', I ran the 'Readiness tool', all to no avail. Please help.
 

Question Info


Last updated October 13, 2018 Views 16,425 Applies to:
Answer

...after spending hours and hours trouble shooting this issue with MS Support, to no avail, it was decided to do an 'Install-Repair'.

After the 'Install-Repair', win7 reported a corrupted 'NET-Framework v4'. After Win7 fixed this, all the updates were downloaded and installed. Finally, the last update, being SP1, I ran the 'Hotfix', before the SP1 install. SP1 installed without any issues.

 

Hope this helps someone!

 

Cheers!

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.