Error Code: 0x80071A91 (Can't install SP1)

I am having an issue installing W7 SP1.  I tried this when it first came out but then it encountered the "Service Pack did not install.  Removing changes to system" problem and my computer got stuck in an infinite loop of rebooting and displaying this message.  I eventually got it to system restore to a previous restore point and everything was fine.  I decided to put off installing SP1 until today.  Now, it claims that it has downloaded and installed SP1 but when I reboot the computer it says it cannot proceed without rebooting even though I've just done that.  I've already used the System Update Readiness Tool as well as sfc/scannow which don't produce any errors.  I've also checked the drive and fixed any problems as well as turning off my antivirus while installing SP1, but to no avail.  Moreover, now it can't system restore because of failure 0x80071a91.  I've looked in the cbs.log file and noticed some "failure" messages, but when I try to uninstall the mentioned updates and what not, sometimes it says it isn't completely uninstalled or there isn't even an option to uninstall.  Any help is appreciated.
Answer
Answer
 

See KarthiK TP's reply to an earlier post involving the error:


http://social.answers.microsoft.com/Forums/en-US/vistawu/thread/b7aafde8-f086-478b-ae0d-d66ef055009e>

`~`

03/17/1109:14:59 pm

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated November 9, 2019 Views 1,728 Applies to: