Blue Screen (Stop 0x50) after applying update KB2982791 to Windows 7 Home Premium 64 bit

Yesterday I ran all the updates of the August patch day. Installation went smoothly. After rebooting everything worked fine. But when I shut down my notebook and switched it on a little later it came up with a blue screen with a Stop 0x50 in Win32k.sys. I could not even boot into safe mode as Windows failed to start no matter which mode chose.

So I restored from a backup, installed the updates again and... same effect. After restoring again I went through the updates and found update KB2982791 which relates to Win32k.sys and fonts. I also found this KB article (Stop error 0x50 in Win32k.sys) which says that a Stop 0x50 occurs because Win32k.sys crashes when the font cache is not correctly maintained. Quite a bizarre behaviour to crash the whole operating system because a cache seems to be invalid. A decent programmer would have just cleared the cache and continued.

Since security update KB2982791 relates to fonts, as well, I guess that MS has once again messed up an update.

From my experience with MS "support" I know that MS does not care about bug reports. So I just post this to inform people which may have been bitten by this bug. If possible, restore your OS or boot from CD and uninstall update KB2982791. Then things should work again. Oh, and after that switch off automatic updating...





I had the same problem on two computers, both win7 64bits.

I could solve it by booting from a DVD and removing the following file:


For sake of completeness, I first removed the files



But that didn't solve the problem. Then I removed the file I mentioned first. So, in the end all 3 files were removed, but I guess the first one is the culprit.

[Susan moderator here, I'm marking this ONLY as an answer so that it shows up at the top.  This is a workaround - NOT a real answer. We still don't understand why this is happening and what the root cause is.]

4 people found this reply helpful


Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.


I can confirm that removing fntcache.dat fixed the issue.

My dad had this issue on his win7 x64 PC after the update that he received on 15-08-2014.

Checking the update history, He only received KB2982791, not the other mentioned suspects.

Removal of fntcache.dat via command prompt via de recovery disk solved the problem.

For anyone having issues removing the file with commandprompt, here is my quick guide:

1. Insert the recovery disk/windows installation disk.

2. Boot from disk by pressing F12 or whatever key is shown when your PC turns on that says "BOOT MENU" or something alike.

3. Select CD/Disk Drive

4. Let the windows files load, select a language and then select the restore option on the bottom.

5. Then select the top option to get a list of all the repair tools.

6. Click on command prompt on the bottom.

7. You'll see a letter, for example X:\. This is your windows CD. We need to get to the windows installation on your hard drive, but even though this might have been C: when your PC was still working, it could very well be another letter now, so to try this out, first type:

wmic logicaldisk get name

to get a list of all your drives. Then access every disk you see in that list by typing:

cd /d A:
cd /d B:
cd /d C: 

and so on, each time checking what's on the drive by typing dir.

If you see a list that contains folders like "Windows" and "Program Files", you're most likely on your harddrive that contains your windows installation.

8. Now go to the system32 folder by typing:

cd windows

cd system32

9. Now check if the fntcache.dat file exists, by typing:

if exist fntcache.dat ( echo yes ) else ( echo no )

10. If you see "yes" below that line, this means that the file exists, and your problems will most likely be fixed very soon.

11. Type the following command to remove the file:

del fntcache.dat

12. Press <arrow up> twice, to repeat the "if exist fntcache..." command. This should now output "no".

13. If that's the case, reboot your computer and keep your fingers crossed. This worked for me :-)! Good luck. If it still doesn't work, I suggest you follow the steps to remove the entire faulty windows update by following the instructions elsewhere in this topic, that I'll also post below (my own version, for your convenience):

1. Once you know the letter of your windows drive (see my tutorial above), type the following command (replace C: with the letter of your drive that contains your windows installation):

dism /image:C:\ /get-packages

2. Search the results for the faulty security update KB2982791, and just to be sure, find KB2976897 and KB2970228 as well.

3. Write down the exact package names, and remove them with the following commands (replace drive letter again to fit your system, and replace the package names with how they're named on your system):

dism /image:C:\ /remove-package/PackageName:Package_for_KB2970228~31bf3856ad364e35~amd64~~

dism /image:C:\ /remove-package/PackageName:Package_for_KB2982791~31bf3856ad364e35~amd64~~

dism /image:C:\ /remove-package/PackageName:Package_for_KB2976897~31bf3856ad364e35~amd64~~

4. You'll receive messages that state that the uninstallations were successfull.

5. Restart the computer into normal mode.

16 people found this reply helpful


Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.


Question Info

Last updated September 6, 2020 Views 195,568 Applies to: