Windows Media Player only runs in "Run as Administrator" mode

I just bought a new computer with Windows 7 installed.  When I clicked on Windows Media Player icon in the task bar it brought up an install dialog box, which had choices for standard and custom installs.  I chose the standard install.  Now when click the icon in the task bar nothing happens.  I have to go to Start/All programs/Windows Media Player and right click and then run it as an administrator to get the dang thing to work.

I need to get this working right because I have a Rhapsody To Go subscription and the DRM stuff will not work until I get Windows Media Player running "normally."

I did run sfc /scannow from the command prompt but it advised me that all was well on that front.

Help!!
 

Question Info


Last updated October 28, 2018 Views 5,717 Applies to:
Answer
Hello AlamedaTom,

Thank you for posting to the Microsoft Answers Forum.

Have you installed any codecs lately that might be interfering with Media Players permissions? If so, then remove the additional codecs and try to run Media Player again.

Try this:
1. Right click any application shortcut icon and click the "Advanced" button on the Shortcut page to get to the Advanced Properties dialog.

2. Now you will see a option checkbox for "Run as administrator", click the checkbox and press "OK" button at the bottom.

3. From now on, the application will always run as administrator if you use the shortcut to launch it.

Please reply back and let us know if you still need assistance.

Sincerely,
Marilyn
Microsoft Answers Support Engineer
Visit our Microsoft Answers Feedback Forum and let us know what you think

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.