Windows 7 keeps on writing thousands of jpg files on c:\windows\serviceprofiles\networkservice\appdata\local\microsoft\media player\art cache\localmls subdirectory as system files.

gnf0512 asked on
Let me describe what is happening. I used the "get info" in iTunes to add various jpg artwork at the individual CD level (i.e., selecting multiple song at the same time).  Itunes displays the artwork fine and works fine. Over a period of time I noticed system performance deterioration and when I tried to create a disk image using CMS Bounceback Ultimate noticed that the number of files on my hard drive had increase from 250,000 to approximately 1,000,000. After a lot of investigation and a little luck I determined that Windows 7 writes these jpg files repeatedly in the c:\windows\serviceprofiles\networkservice\appdata\local\microsoft\media player\art cache\localmls subdirectory. These are the same jpg files I added in iTunes. At the time of my discovery there were approximately 700,000 of these small files written in this subdirectory as system files which are hidden files. I was able to delete these files by first resetting the file attributes (attrib *.jpg -s -h -r) and then using the del command. Unfortunately, the system continues to write the same files in the same sub and within hours I have thousands of these files written again. I checked the system for viruses/malware using the latest versions of sophos, malwarebytes, and spy hunter. There is no malware reported by any of these programs.  I also stopped Sophos and tried again but problem continues. I also reconstructed the iTunes library using the steps described by Apple but this did not solve problem. Any suggestions what I can try next?
44 people had this question

Abuse history

The answered status icon Answer
HrvatTuk replied on

This same issue caused my anti-virus program to take over 20 hours to run its complete system scan.  I found over 871,000 art cache files that look to come from browsing's music store. 

I deleted the art cache files by deleting the windows\serviceprofiles\networkservice\appdata\local\microsoft\media player\art cache\localmls folder and creating a new folder witht the same name.  To prevent the folder from filling up again with art, I disabled the Windows Media Player network sharing service using the procedure described in this link:

Now my slow scan probelm is gone.  It took only 3 hours, 15 minutes to run a scan of 750GB internal drive and a 500GB external drive.




Be the first person to mark this helpful

Abuse history

The answered status icon Answer
Linney replied on

"Turning off the "Windows Media Player Network Sharing Service" has seemed to stop it... for now =)"

Missing Hard Drive Space (windows 7)

Alternatively perhaps you create a batch file to run at Startup or by Schedule Tasks to delete *.jpg files that appear in that folder?

A rough example of a batch file would be along these lines. It would be created in NotePad but saved as a .bat file.

cd "windows\serviceprofiles\networkservice\appdata\local\microsoft\media player\art cache\localmls"
DEL *.jpg





That is only a rough guide and may need plenty of amendments by you as I am not that familiar with batch files but it should not be too hard to do.  The batch file when run manually or in Scheduled Tasks would need Administrator privileges or the access permissions of localmls set suitably for the user.

Be the first person to mark this helpful

Abuse history