Unable to Print to Any Printer - Error 0x7e

See system details below.

I am unable to print to any printer including "Send to OneNote". Printing a test page results in error 0x0000007e. Using Notepad reports "The handle is invalid".

The printer is an HP PSC 1600 All-in-One.

I removed and replace Windows Fax and Scan. I can scan a document so the printer and connection are functional.

The event log for for the PrintService reports the following error:

The print spooler failed to load a plug-in module C:\Windows\system32\spool\DRIVERS\W32X86\3\FXSUI.DLL, error code 0x7e.

This failure is not surprising since that file is not present in the subdirectory.

I tried copying that and the other FXS dlls into the subdirectory but that didn't work either.

I have recently installed the following updates using Windows Update:

Microsoft SQL Server 2005 Express Edition Service Pack 4 (KB2463332)

Windows 7 Service Pack 1 (KB976932)

I have tried two different printer troubleshooters but they do not find any error.

I have searched the Registry and there are several instances where FXSUI.DLL and the other FXS dlls are referenced.

Thanks for your help.

Bob

Here is the system information:

Host Name:                 *** Removed for security ***
OS Name:                   Microsoft Windows 7 Ultimate
OS Version:                6.1.7601 Service Pack 1 Build 7601
OS Manufacturer:           Microsoft Corporation
OS Configuration:          Standalone Workstation
OS Build Type:             Multiprocessor Free
Registered Owner:          *** Removed for security ***
Registered Organization:  
Product ID:                00426-292-7190202-85465
Original Install Date:     1/15/2010, 5:14:09 PM
System Boot Time:          3/3/2011, 10:20:28 AM
System Manufacturer:       Dell Inc.               
System Model:              Dell DXP061                 
System Type:               X86-based PC
Processor(s):              1 Processor(s) Installed.
                           [01]: x64 Family 6 Model 15 Stepping 2 GenuineIntel ~1862 Mhz
BIOS Version:              Dell Inc.                 2.3.0 , 1/15/2007
Windows Directory:         C:\Windows
System Directory:          C:\Windows\system32
Boot Device:               \Device\HarddiskVolume3
System Locale:             en-us;English (United States)
Input Locale:              en-us;English (United States)
Time Zone:                 (UTC-07:00) Arizona
Total Physical Memory:     2,046 MB
Available Physical Memory: 1,056 MB
Virtual Memory: Max Size:  4,092 MB
Virtual Memory: Available: 2,790 MB
Virtual Memory: In Use:    1,302 MB
Page File Location(s):     C:\pagefile.sys
Domain:                    MSHOME
Logon Server:              \\*** Removed for security ***
Hotfix(s):                 14 Hotfix(s) Installed.
                           [01]: 982861
                           [02]: KB971033
                           [03]: KB958559
                           [04]: KB2305420
                           [05]: KB2393802
                           [06]: KB2425227
                           [07]: KB2479628
                           [08]: KB2484033
                           [09]: KB2485376
                           [10]: KB2488113
                           [11]: KB2502285
                           [12]: KB958488
                           [13]: KB976902
                           [14]: KB976932
Network Card(s):           2 NIC(s) Installed.
                           [01]: 2Wire 802.11g USB Wireless LAN Card
                                 Connection Name: Wireless Network Connection
                                 DHCP Enabled:    Yes
                                 DHCP Server:     192.168.0.1
                                 IP address(es)
                                 [01]: 192.168.0.3
                                 [02]: fe80::b093:f0bd:3cb9:c94
                           [02]: Intel(R) 82566DC Gigabit Network Connection
                                 Connection Name: Local Area Connection
                                 Status:          Media disconnected

 

Question Info


Last updated December 9, 2019 Views 7,941 Applies to:
Answer
Answer
Turning the printer off, removing it using the Control Panel, and turn it back on solved the problem.

I am happy with that but I don't understand why it worked with Windows 7 before the service pack but did not work after Windows 7 SP1 was installed.

Thank you for you answer.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.