Windows 7 support has ended

Get Windows 10 to continue receiving support.

Upgrade now

Microsoft Keyboard Layout Creator 1.4 on Win 7 SP1

I tried to install Microsoft Keyboard Layout Creator 1.4 on my x64 machine running Windows 7 SP1.

The program installs without any error message, but when opening it, it shows only a gray screen where the keyboard preview should be.

I downloaded the latest version from the following site, where the system requirements list "Windows 2000, Windows XP, Windows Server 2003, Windows Vista, or Windows 7. (MSKLC 1.4 will not run on Windows 95, Windows 98, Windows ME, or Windows NT 4.)"


Then I installed MKLC with Administrator privileges as suggested in this thread:


This didn't solve it.

Later I tried this solution:


going back to Windows XP. Without any success.

Any further ideas? Thanks in advance.
 

Question Info


Last updated January 6, 2020 Views 3,351 Applies to:

Hi,

I would suggest you to perform clean boot and check.

How to troubleshoot a problem by performing a clean boot in Windows Vista or in Windows 7

http://support.microsoft.com/kb/929135

Note: After troubleshooting, make sure to put the computer to start as usual as mentioned in Step 7 in the above KB article.

I would suggest you to contact the manufacture of your keyboard and check.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks, I will give this a try!

In the meantime I have tried a couple of different approaches, but none of them worked.
I searched on the internet and saw that I am not the only one experiencing this problem:

http://www.vistax64.com/software/214192-help-microsoft-keyboard-layout-creator.html
http://www.vistax64.com/vista-general/59394-ms-keyboard-layout-creator.html
http://boardreader.com/thread/windows_keyboard_layout_creator_1v915__c0ce230c-6bc0-48f5-a671-3da79dd1eaa3.html
http://www.pcreview.co.uk/forums/help-microsoft-keyboard-layout-creator-t3380566.html
http://social.microsoft.com/Forums/en-IE/genuinefeedback/thread/85efc569-6f08-4768-8d2e-abdfad50a7a1

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I found the solution.

You need to uncheck "Use Windows XP style DPI scaling" under Windows display options > "Set custom text size (DPI)".


6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.