Internet explorer/Firefox unable to open php files

Hi All.

I am having problems with being able to open php files with the above browsers, the same files I have no problems opening in XP.

All I see when opening up in Windows 7 is the source, I also find if using Windows Explorer to browse through folders that have both HTML and php files shown the former has the usual "e" button but the php file does not have the same marking.



Question Info

Last updated April 14, 2020 Views 3,510 Applies to:
Hi nico hyde,
Looks like a file association issue.
Step 1:
a. Open the folder that contains the file you want to change.
b. Right-click the file that you want to change, and then, click on Open With and then select Choose Default Program [Internet Explorer\Firefox].
Step 2:

If a program does not show up in the list when you right click on it, you can make the program a default by using Set Associations. Use this option to choose which programs you want Windows to use, by default.
a. Open Default Programs by clicking the Startbutton, and then clicking Default Programs.
b. Click Associate a file type or protocol with a program.
c. Click the file type or protocol that you want the program to act as the default for.
d. Click Change program.
e. Click the program that you want to use as the default for the file type you selected, or click the arrow next toOther Programs to show additional programs. (If you don't seeOther Programs, or your program is not listed, clickBrowse to find the program you want to use, and then clickOpen.

 f.  ClickOK.
Change the program that opens a type of file:
When you run an .exe file on a Windows Vista-based or Windows 7-based computer, the file may start a different program:
Manasa P – Microsoft Support.

3 people were helped by this reply


Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.