Question

Q: Installer "stalls" at copying mfc42.dll

Tried to do a clean install of BK 6.4 This PM.  I have the downloaded install *.exe file on the desktop, User, Administrator.   

In the last Start window in the BK installer I click "Next", within a few seconds file copying "stalls" and I get this error window saying, ““C:\windows\system32\mfc42.dll” could not be opened.  Please check. . .disk capacity. . .access to destination directory”. 

So, yes I can access the \BK\ folder with WN Explorer.  And I have 40 per cent of my SSD OS partition free. 

I think the error window tells me the installer was unable to copy the file Mfc42.dll.

My OS, WN 7 Pro 64 is in C:\Windows.

I did run the installer from User:Administrator.  I also did try this:  RIGHT click BKSETUP6.EXE and pick Run as Administrator?

I still needed to install other software.  Those installs went A-OK.

I deleted the original BK download and grabbed a fresh download of bksetup6.exe.  The file sizes matched so I do not think I inadvertently corrupted my first download from bkwin.org. 

I shut down all programs and turned off Norton's software.  I then shut down, disconnected my network cable and rebooted my WN 7 PC without any network or Internet connection.

I tried the install again accepting all defaults and I get the same error result.

After the install "crashes" I find this file in the default destination directory for the BK program files; (unwise.exe, 148kb, mod date 25 Jun 1999).  So, I think the "wise script" installer is reading the correct path as to where to copy the uninstaller.

Now looking at that file mfc42.dll. I see attributes read only box is blank, size is 1.32mb, created is 7/13/09  5:35PM, mod is 7/13/09 6:41 PM. 

OBTW This geneology software installs A-OK on my WN XP Pro SP3 PC.

Thanx in advance,

Pete

Answer

A:

Ignore any of the free scans mentioned on this site, but a read of the other information might help.

How To Fix Mfc42.dll Errors
http://www.personalcomputerfixes.com/general-errors/how-to-fix-mfc42-dll-errors/

 

 

"many programs load their own copy in their own folder "

How many mfc42.dll do you have on your machine?  Make sure any extra versions (especially any in Program Files) are the same version as the one in the System32 folder.

 

It may be necessary to show Both Hidden and System Files, and also to uncheck "Hide known file types" in Control Panel/ Folder Options/ View, to search thoroughly.

 

As many of your files may not be in indexed locations you may find this free program (run as an Admin) handy to know about.  I can recommend it and use it all the time myself.

 

SearchMyFiles v1.71

http://www.nirsoft.net/utils/search_my_files.html 

Did this solve your problem?

Sorry this didn't help.



 
Question Info

Views: 5,414 Last updated: June 21, 2018 Applies to: