Q: Error message: "Cannot connect to Service Control Manager", when trying to run Free Serial Port Monitor. This thread is locked from future replies

Trying to run some newly acquired software, Free Serial Port Monitor, I get a message: Can not connect to Service Control Manager ( you need to have administrative privilege to access the Service Control Manager). 

Since I am logged on as an Administrator I haven't a clue what to do - except, of course, curse Microsoft!

Hi CouncillorJB,


1. Does this happen only when you try to run Free Serial Port Monitor?

2. Is your system connected to a domain?


Method 1:

You may try running the program using Administrative privileges and check if it helps:

How do I run an application once with a full administrator access token?


Method 2:

You may temporarily disable security software and firewalls installed on the system and check if the issue persists.

Note: Make sure to enable the security software on the computer after checking for the issue.

Microsoft-Forum Moderator

Did this solve your problem?

Sorry this didn't help.

2 people were helped by this reply

Many thanks for trying to help me so quickly.  I have only just been able to follow your suggestions.

My initial outcome is lack of success, with much tearing of hair.

I think I'm out of my depth. When I download a program I'm stupid enough to expect it to work.

In answer to your questions:

1.  Yes, but all I want to do is look at what is arriving on my serial port(s) and I haven't wanted to do this before.  I'm trying to crack a problem on my boat where my navigation software doesn't receive any NMEA data from my USB port which is attached to my instruments using a USB/Serial converter.  The instruments seem quite happy to talk to each other and when I had a computer with an old-style serial port they talked to the computer as well.  I suspect that the baud rate is wrong, my instruments talk at 4800 baud but this darned computer won't let me change the baud rate from 9600 - more accurately it seems to let me but when I go back to check I find my changes have been ignored.  Talking about the specific application, when I try to run it as an administrator (even though I'm already one) it just reinstalls itself.  It's not that important, after all if you drown you drown!

2.  Tried it without success.

Thanks again


Did this solve your problem?

Sorry this didn't help.

Hi JohnB,


This is likely to be a compatibility problem- quite possibly because of the baud rate you have mentioned. The best thing you can do is try an older computer or see if you can contact someone local to help.

Microsoft-Forum Moderator

Did this solve your problem?

Sorry this didn't help.

1 person was helped by this reply

Right click the shortcut.

Troubleshoot compatibility.

It should select a compatible methodology of opening the program.

Tested and working as of the time stamp of this post.

Did this solve your problem?

Sorry this didn't help.

36 people were helped by this reply

Question Info

Views: 14,676 Last updated: March 24, 2018 Applies to: