Error 1935 HRESULT: 0x80070422

I am attempting to install Adobe Lightroom 5 on a Dell XPS 13 laptop running Windows 7 Professional SP1 (64 bit OS). During installation, Error 1935 ....HRESULT: 0x80070422 gets returned. I searched for solutions through MS Support and Adobe Support to no avail. I have tried at least the following:

Uninstall .NET Framework 4 and related components.
Reinstall .NET Framework 4 (tried to start with 3.5 and earlier, but they don't install either)
Clean Booting with .NET, without .NET, with internet connectivity, without internet connectivity..
MS Fix It Tool
Installed Windows Updates
Restarted at least a hundred times, and after each step

There are numerous other methods, suggested by both MS and Adobe for rectifying this issue and I have narrowed the problem down Windows.

Please, anyone who has ideas on this feel free to join in.
Answer
Answer
I had the same problem. Turns out my Windows Modules Installer service was disabled. Go to Control Panel, Administrative Services, Local Services. Make sure the startup type for Windows Modules Installer (TrustedInstaller) is set to Automatic. 

170 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated October 27, 2020 Views 16,645 Applies to: