Cannot turn DEP back on after turning it off.

Original Title: Cannot turn DEP back on after turning it off using bcdedit.exe /set {current} nx AlwaysOff (Window 7 Home Premium version

I got a old software cannot run on Window 7. So I tried to make it work by turning off DEP with

bcdedit.exe /set {current} nx AlwaysOff
bcdedit.exe /set nx AlwaysOf

It did not help, the old software still not working. Anyway, I tried to turn DEP back on with both

bcdedit.exe /set {current} nx AlwaysOn
bcdedit.exe /set nx AlwaysOn

But I still see in Performance Options / Data Execution Prevention DEP still off

 

Question Info


Last updated June 9, 2019 Views 17,730 Applies to:

I got a old software cannot run on Window 7. So I tried to make it work by turning off DEP with

bcdedit.exe /set {current} nx AlwaysOff
bcdedit.exe /set nx AlwaysOf

It did not help, the old software still not working. Anyway, I tried to turn DEP back on with both

bcdedit.exe /set {current} nx AlwaysOn
bcdedit.exe /set nx AlwaysOn

But I still see in Performance Options / Data Execution Prevention DEP still off.

 

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Windows 7, Programs forum would be a better choice for your issue :
http://social.answers.microsoft.com/Forums/en-US/w7programs/threads

This is Vista forum.

t-4-2

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks. First time here.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Aznable0078,

 

·        Did you restart the computer after executing the command?

 

Restart the computer and check for the status again. Check if the following steps help, in case this does not work.

 

Step 1: Check to see if changing the settings helps. Refer the below mentioned link for the same.

Change Data Execution Prevention settings

 

Step 2: Uninstall the offending program completely from the computer and check the status.

Uninstall or change a program

 

Step 3:  If this does not help, then run the following command and check if the issue persists.

 

1.      Click Start and type cmd in the start search box.

2.      From the programs list right click on cmd and select “Run as Administrator.”

3.      In the command shell type the following command and press enter. (Restart the computer after executing this command)

bcdedit.exe /set {current} nx OptIn

 

NOTE: If for some reason this command does not enable DEP after restarting the computer, then use the” bcdedit.exe /set {current} nx AlwaysOn(without quotes) command instead.

 

Regards,
Syed N – Microsoft Support
--------------------------------------------------------------------------------------------------------
Visit our Microsoft Answers Feedback Forum and let us know what you think.

9 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.