Q: Cannot open the citrix online plug-in This thread is locked from future replies

My work runs a remote access server through Citrix, I can log on but can't open any of the applications receiving the 'cannot open citrix online plugin' msg.  I've tried uninstalling and installing multiple times, I've installed the latest plug-in I've checked the application compatibility, ensured it's listed as a trusted site, made sure it's not being blocked by my firewall, searched the citrix site for fixes and installed everything on there - I'm at a loss !  


The work IT guys have no idea either telling me it must be my laptop however my RAS worked Thursday, they updated their system Friday and RAS didn't work Saturday - like I said they have no idea.    


Has anyone else had this problem and worked out how to fix it ?

Try resetting Internet Explorer and reinstall the plug in to see if it works:'

Click Start, type: Internet Options
Hit Enter
Select 'Advanced' tab
Under Reset Internet Explorer Settings, click 'Reset'

This should restore Internet Explorer to its default settings.


For additional support you can contact Citrix Support site:


You will need to go to the Windows 7 Support forums at the following link for help with troubleshooting your problem:

Windows Insider MVP
MVP-Windows and Devices for IT

Did this solve your problem?

Sorry this didn't help.

Thanks for the reply, I reset Internet Explorer and tried everything else suggested in the articles, lfixes etc unfortunately nothing worked.  If I have the preference set on native client it still tells me I cannot open citrix plug in, if I have it set on Java it looks like it's going to open then tells me there iis a problem with Internet Explorer which closed and reopened - any other suggestions please ??  

Did this solve your problem?

Sorry this didn't help.

As Andre stated, it would be best to post in the TechNet for ITPRO but if it worked one day and didn't the next day, you might want to try a system restore to before the problem ocurred.

To choose a System Restore point,

·         From the Desktop click the Pearl (start) button
·         In the Search Field type “System Restore” and hit enter
·         Once System Restore is open, select the option “choose a different restore point” and hit next

Once on the next screen, pick a restore point to go back to when it last worked for you. Once you select the restore point, click next, then select finish, this will start the restore process.

If you go to System Restore, do you see any available restore points?
Go to Start. Right click on computer. Go to Properties.
On the left hand side, click on System Protection.
Click on System Restore button. Click on Next.
You should see system restore points when changes to your computer were made.
I have several for when Windows Updates were installed.
At the bottom left, put a check mark in Check more restore points.
You should see more restore points.
Highlight the one you have before it stopped working.
Click next. This will confirm the restore point you want to install.


Since you are in a work environment, system restore may not be available to you as your IT department may have limited your ability to do so.

Hope this helps.

Did this solve your problem?

Sorry this didn't help.

Question Info

Views: 12,914 Last updated: March 18, 2018 Applies to: