Question

Q: C++ Errors With Quattro pro (Solved)

Hello,

Just installed Corel Family Pack 5 in a Windows 7 64bit system. This is a new clean system. Word Perfect runs fine but I get errors with Quattro Pro. I have found similer threads but not good answer.

The error is as follows:

Microsoft Visual C++ Runtime Library
Runtime Error!
Program: C:....
This application has requested the Runtime to terminate it in an unusual way.

Then nothing happens the program will not run. Have tried uninstalling and reinstalling with no success.

I have found a small but rather odd work around for the issue but don't understand how this work around could possible work. I discovered this by accident. I remembered that the first day I saw Quattro Pro work as I tested it when I installed it.

I then began to think and remembered the file I tested was on a flash drive. So I pulled out the flash drive and found a file and clicked it, everything opened as it should. Could even open the program from the shortcut in the start menu. So I then copied the file to the desktop safely removed the flash drive and tried to open the file and got the same errors again. Replaced the flash drive and all works again.

Decided to try other flash drives even blank ones with no files on them what so ever and lo and behold with a flash drive plugged in Quattro Pro (11) works just fine. Take the flash drive out and it quits again.

I don't quite understand what having a flash drive any flash drive attached would have to do with the program working but it does. It would be great if someone had an answer to this issue. However at least I can use the program with a flash drive plugged in.

Thanks in advance for any replys to this. May be a couple days before I can get back.

 

V

Answer

A:

After hours of searching the internet I finally found a solution to this issue. I found other people asking the same question but no answers. I finally happened upon the solution right on the Corel Website. I had checked it several times before but could not find the answer.

The solution is very simple but does require going into the registry.

This is a quote from the Corel Page.

Ok I know it says Vista but I took a chance and tried it on Windows 7 64bit and it worked.
Please note in the registry path it states a key folder called 13, that is actually a variable as I have Family Pack 5 and my 13 was called 11. So it appears this issue is also on Quattro Pro 11, 12, and 13 maybe even older and newer versions too.

Deleting this key deletes the Quattro Pro Recient list. 

"Answer ID   760250   -       Why do I get a Visual C++ Runtime Library error when launching Quattro Pro®?

   

Some users report intermittent errors, such asVisual C++ Runtime Libary error causing an Abnormal Program Terimination when launching Quattro Pro® on Windows VISTA.

This issue has been reported to our development team.

   

To workaround this issue:

  1. Click Start, Programs, Accessories and Run.
  2. In the open window, type:  regedit and click OK.
  3. Choose the following path HKEY_CURRENT_USER\Software\Corel\User Assistant\13\Recent Work\Quattro Pro\
  4. Right click on the Quattro Pro folder, select delete.
  5. Say yes when prompted to delete the key.
  6. Close the Registry Editor
  7. Launch Quattro Pro"

Link to the full article on Corel Website.

Did this solve your problem?

Sorry this didn't help.

16 people were helped by this reply



 
Question Info

Views: 7,257 Last updated: July 2, 2018 Applies to: