After installing iTunes [yes, latest version, 9.2 (32-bit) that is] when I try to start the program I receive the following error - "Error 46: Could not find or load activex control"

OS - Windows 7 Ultimate, 32 bit.

Things I have tried:

Installed the latest version of iTunes (9.2 that is) - yes, 32-bit. No mistakes there. Oh, I did install it in so-called admin mode (right-click > run as admin thingy) It installs fine. But when attempting to run (open) the program by double-clicking I receive the aforementioned error!

Tried removing iTunes using this Windows Installer Cleanup Utility and another similar program Revo uninstaller and reinstalling iTunes with admin privileges. No luck again! Error message continues to haunt...

Tried it with a new admin user account. Heck! I receive the same error message.

Next up, I disabled my Eset antivirus and Outpost firewall pro and tried installing the program. It installs fine. But when I try to open -- Well well, no surprises there! YES I continued receiving the aforementioned error yet again!

I even tried this clean boot procedure next. Disabled all 3rd party stuff etc.. No luck again!!

Next I disabled UAC settings (after a friend's recommendation), installed the program. It installs fine. But while opening, Yes, you guessed it - it throws up this haunting error: "Error 46: Could not find or load activex control"

What next??

 

Question Info


Last updated March 24, 2018 Views 1,193 Applies to:
Answer

Thank you all!

I have finally managed to fix the never ending saga of iTunes error 46 problem!

I did some googl'ing and researched for a solution after posting the issue here on this forum.

And guess what? I seem to have come back to this very forum where I found the exact fix.

Here's the solution link: http://social.answers.microsoft.com/Forums/en-IN/w7programs/thread/be345db1-4468-4077-b379-321aa2adf6d4

Method 1 took me nowhere! I had already tried that without any success!

Method 2 looked promising. Voila! It was this that did the trick.!

I am a happy man after hours of researching!

Apple folks have got to pull up their socks!

P.S Step f under Method 2 is the most imp step.  To run the .cmd file in vista compatibility mode. (I tried running without the compatibility settings which didn't fix the issue)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.