Cannot Change Compatibility Mode

I am trying to run an application on a new Windows 7 PC.  It runs fine with no special settings on an identical Windows 7 PC (same model number, same OS, same updates to the OS).  But on the second machine Windows will not allow me to change compatibility mode to Windows 7.  It insists on locking me into other compatibility modes and then greys out the selection to change it back to Windows 7.  Worse, every time I run the program I have to answer the nattering question "do you want the following application to make changes to this computer?"  - yes!  whatever!  just leave me alone and run the application!

1) how do I stop this nattering and force Windows 7 to leave me alone and run the application?

2) how do I switch compatibility mode back to Windows 7 (or eliminate comaptibility mode altogther) for this application?

I have uninstalled and reinstalled the application several times with no luck.

Question Info

Last updated September 19, 2018 Views 32,102 Applies to:
Yes, lowering the UAC slider leaves your pc more unprotected, that's why I mentioned to only use it as an experienced user (...knowing your way around your pc...)

Does this problem occur only with the .exe in question btw?

You can always work around a problem through the register. I found this (below) on more than one site. Before starting I STRONGLY suggest you make a backup of the register . How? Type regedit in the searchbar in the startmenu and press enter, confirm UAC, click File -> Export, choose a filename and select where you want to save the exported .reg file to, select (dot) the All option under Export range , type in a name for the .reg file, and click on the Save button.
!The register is not a place to fool around if you don't exactly know what you're doing. You'll pay dearly if something goes wrong!
You can access the register by typing regedit in the search bar in Startmenu but you probably already know this.

All of the settings in the Compatibility tab can be set via the registry

- open REGEDIT
- goto "HKEY_CURRENT_USER\Software\Microsoft\WindowsNT\CurrentVersion\AppCompatFlags\Layers"
- create a new String Value
- name or rename it as the application full path e.g. " C:\Program Files\Internet Explorer\iexplore.exe "
- right click on the new String and select Modify
- type RUNASADMIN in the Value Data row; this will classify the program to be run as Administrator.
This allows you to bypass the GUI mode of settings editing. Instead you edit the settings by registry. And of course you can ignore the advanced
properties of the shortcut. Better launch the program in default
administrator mode ! :o;)

I've used it for Internet Explorer (iexplore.exe) that is part of the


A desktop shortcut can be set to run as administrative mode.

But, if i launch the IE7 browser from a URL or Favorite link this won't
work and Windows Vista will run it in User Mode... UNLESS I'VE CHANGED
THOSE OPTIONS WITH REGEDIT. To run regedit go to Start Menu and then
"Run..." type REGEDIT.EXE or REGEDIT.

Other Options and some examples
Always in the key called HKEY_CURRENT_USER\Software\Microsoft\Windows
NT\CurrentVersion\AppCompatFlags\Layers u can add more variables:

RUNASADMIN: i've just told, Run That Program As Administrator

256COLOR: Run the program in 256 colors;
640X480: add this value to run a game or other application in a lower
DISABLETHEMES: add it to disable Windows visual themes 4 that app;
DISABLEDWM: Disabled desktop composition;
HIGHDPIAWARE: Disable display scaling on high DPI settings;

ELEVATECREATEPROCESS: i dunno, unknown function. :confused:

COMPATIBILITY VALUES (don't use'em together, only one per app !):

WIN95: to add Windows 95 compatibilty mode;
WIN98: to add Windows Millennium or 98 compatibility mode;
NT4SP5: NT 4.0 Service Pack Five Com Mode;
WIN2000: type it to add Windows 2K compatibility mode;
WINXPSP2: Windows XP Service Pack 2 compatibility mode;
WINSRV03SP1: Windows Server 2003 SP 1 com mode.

Windows also creates these option strings when you change Compatibilty

Settings in the properties of the selected executable (GUI mode, Not
Regedit Mode).

Found on: Forums.techarena

REGEDIT IS AWESOME, BUT USE IT AT YOUR OWN RISK! Start with a registrybackup!!!

Good luck and keep us posted please!

Error. No keyboard found. Hit F1 to continue...
There's no place like

1 person was helped by this reply


Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.