Windows believes it's not genuine and won't let me attempt to activate.

There's been some weird stuff with my machine lately, I'll tell the long story.

I've had Windows 7 Premium running on my Asus desktop since whenever they sent me the upgrade, probably mid-2010. It's an upgrade from whatever

copy of Vista was running at the time of purchase in October 2009. Some time last week (the 21st), despite control panel assuring me I was

activated I received a warning that Windows was not genuine. Since Control Panel gave me an activation thumbs up, I went about my merry way.

On the 22nd, some of my profile settings got screwed up. For the sake of non-technical users in the household I have usernames displayed on

startup to enable a nice "click and enter password" experience. That went away for some reason. I went around in circles on that one until I

found some information that suggested sometimes the profiles get corrupted in the registry and need to be fixed. It also said if you were lazy

you could delete them, and it was bedtime so I gave it a quick shot. Reboot, everything looks peachy, so I went to bed and on the 23rd we left to

visit family for the holidays. (Also my car was burglarized that night. Merry Christmas!)

Today's the first time I booted my machine since the 22nd. I was greeted with a loss all of my profile settings (desktop, remapped My Documents,

etc.) which makes sense considering I nuked the registry tree that pointed to the right data. Then WGA started whining that my machine wasn't

genuine again, and this time it's the black desktop of doom where I know it's serious. FizzBin! Here's the things I've tried to resolve this:

    * Trying to reactivate via Control Panel gives me "Access is denied" 0x80070005.
    * Clicking "Get Genuine" in the "you're a pirate YARR!" dialog gives me the same error.
    * System restore says the file or directory is corrupted and unreadable (0x80070570). Trying to run it again yields "Catastrophic failure

0x8000FFF". That's exciting.
    * Trying a different System Restore point bluescreens.
    * slmgr /dlv yields "On a computer running Microsoft Windows non-core edition, run 'slui.exe 0x2a 0x46'. That's... disturbing.
    * slui.exe gives me the same error code as control panel activation.
    * slmgr /dti tells me Permission denied; that's line 835. It's in the DisplayIID method and it looks like it dies trying to run a WMI query.

I'm not sharp with VBS but it looks like it ought to be eating the error.
    * slmgr /xpr from an elevated command prompt is the same error on a different line.
    * slmgr /rilc gives error 0x8007005 Access denied and complains I don't have elevated privileges. (I do!)
    * Same Access Denied error with slmgr /ipk.
    * Some answers on forums seem to indicate this can happen due to borked group policy settings. I'm not on a domain but hey, I'll try

anything. Unfortunately Premium doesn't let you use the group policy snap-in to MMC.
    * The help for activation doesn't have a phone number.

I'm shut out of System Restore. I can't activate. I can't run any of the tools it looks like I'd need to activate over the phone, and I don't

have a phone number to call anyway. I've got one last weapon: I use Acronis True Image and I've got a disk image from the 6th I could restore.

There's no telling if that will work though; if the activation servers think I'm Seasharp the pirate then I'll just get hosed again in a few

weeks. Clicking the link in one of the WGA dialogs kicked off some process that "might take several minutes" I'm waiting on, hopefully that works. It's been 10 minutes so I'm posting the thread anyway because I assume it's stuck. (Actually yes it is. There's a script error on the page: permission denied. Sounds sadly familiar.) What happened to the old checks that let me generate a code and paste it in? I suppose those would fail on my system too.

I'm not some ____ hound looking to run cracked Windows. I'm a C# developer with an MSDN subscription and practically unlimited access to every version of Win7; I still purchased a computer with a Vista license/7 upgrade offer because I feel it's kind of shady to use MSDN for my home affairs. I haven't popped new hardware in the box since November 2009, so I don't know why I would suddenly start appearing as non-genuine. I think this would be solved if I were allowed access to *anything* that would let me activate, but all of the tools claim my administrator accounts don't have enough chops to do the job. What the heck is going on?
 

Question Info


Last updated March 20, 2018 Views 1,884 Applies to:
Answer

Since no one seemed to believe there was an easy solution, I took out a bigger hammer and restored a disk image from earlier in the month. Everything seems to be fine now, I did /ato and the genuine check and both came back clean. Now I've just got to put up with a month of updates to reapply. I'm curious if maybe an update around the 22nd caused the problem; I guess I'll know again once auto-updates are applied.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.