Windows Activation Error : Error Code 0x80070005

I have upgraded my x64 Vista to x64 Windows7. After adding to companies domain, it asked to activate windows again. but its giving the following error when i try to activate it : "Windows Activation Error : Error Code 0x80070005"
 

Question Info


Last updated November 15, 2018 Views 183,080 Applies to:
Answer
To work around this issue, follow these steps:
  1. Click Start, click All Programs, click Accessories, right-click Command Prompt, and then click Run as.
  2. Click The following user, and then select Administrator in the User name list.
  3. Click OK.
  4. At a command prompt, type the following command, and then press ENTER:
Windows Expert - Consumer

52 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Ok, here is the deal.
The problem happens because you have the "Plug and Play" service set by GPO. Sounds weird but have an explanation.
When you set the "Plug and Play" service by GPO, the service is set with default permissions:

Allow - BUILTIN\Administrators - Full Control
Allow - NT AUTHORITY\SYSTEM - Full Control
Allow - NT AUTHORITY\INTERACTIVE - Read

The permissions granted to the "Plug and Play" Service do not grant the Licensing Service (sppsvc) the appropiate rights to access the Plug and Play service.
So, you have 2 solutions

A- Disable the "Plug and Play" service by GPO and let the default configuration works instead the configuration set by GPO. After that, make "gpupdate /force /target:computer" to update the computer policy without restart.

B- Set the permissions in the "Plug and Play" service in the GPO to allow the activation. This issue happens in Windows Server 2008 R2 and Windows 7.

1- Open the Plug and Play service in the GPO. Go to Computer Configuration / Policies / Windows Settings / Security Settings / System Services.
2- Open the service and click in Edit Security.
3- Add the "SERVICE" user with the following allow permissions.

Query template
Query status
Enumerate dependents
Interrogate
User-defined control
Read permissions

Run "gpupdate /force /target:computer" to update the computer policy without restart.

Best Regards

38 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.