Windows 7 install frozen on 'Preparing your desktop'

I just downloaded Windows 7, and its all been installed.  When the computer restarted the final time, I logged in, and now it is frozen on 'Preparing your desktop' and has been for hours.  Should I turn off the computer?
 

Question Info


Last updated July 28, 2019 Views 2,038 Applies to:
Answer
Answer
To access the System Recovery Environment in Windows 7, simply boot your PC, just before the system loads the Windows operating system; hit the [F8] Function 8 key on your keyboard which will launch the Advanced Boot Options menu. There you will see a new option 'Repair Your Computer', select this option and hit 'Enter' on your keyboard.

If the problem persist, try booting into Safe Mode, boot your PC, just before the system loads the Windows operating system; hit the [F8] Function 8 key on your keyboard which will launch the Advanced Boot Options menu. Select Safe Mode.

Log in, click Start, type Device Manager, hit Enter

Expand Display Adapters

Right click your Video card, click uninstall.

Restart your system

Log in, click Start, type Device Manager, hit Enter

Expand Display Adapters
Right click your Video card

Update Driver Software; then click Search automatically for updated driver software.

 Note: Drivers on the Windows Update site are directly provided by hardware manufacturers. Microsoft tests drivers in various environments before they are published; however, we cannot guarantee all drivers will work on all hardware platforms as there are too many different models, although their hardware ID are the same as the standard version. In some cases, due to hardware modifications by different manufacturers, the driver updates may cause some error.

If it does not work on your issue, I'd suggest you installing the Vista driver in Compatibility mode. Remove and rescan that hardware device in Device Manager, right-click on the driver executable/installer file -> Properties and select the Compatibility tab; click the checkbox before Run this program in Compatibility mode for option and select Windows Vista in the list-down box; then try installing the device driver via Run as administrator.

If the problem still persist,

1) Detach all unnecessary peripheral devices from your computer, such as printers, scanners and removable storage devices.

2) Restart the computer.

If the computer starts properly, then its an offending device attached to the system.

If you continue experience problems, log back in,

1. Click Start, type msconfig in the Start Search box, and then press ENTER.
       User Account Control permission
       If you are prompted for an administrator password or for a confirmation, type the password, or click Continue.
   2. On the General tab, click Selective Startup.
   3. Under Selective Startup, click to clear the Load Startup Items check box.
   4. Click the Services tab, click to select the Hide All Microsoft Services check box, and then click Disable All.
   5. Click OK.
   6. When you are prompted, click Restart.
   7. After the computer starts, check whether the problem is resolved.

If the problem continues to exist, I would suggest you power down your system, unplug it, open the system unit and check to make sure components such as your video card and memory are all seated properly.

If the problem is still persisting, try the following:

1. Insert the Windows 7 DVD
2. Restart your computer
3. When asked if you want to boot from your DVD drive, do so.
4. Choose your language, click Next.
5. Click 'Repair your computer'
6. Select operating system you want to repair.
7. On the System Recovery window, click Memory diagnostics option

Restart your system, a scan of your memory of your memory modules will take place to check for any defects.

Best,
Andre
Windows Insider MVP
MVP-Windows and Devices for IT
twitter/adacosta
groovypost.com

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.