Unable to copy files using windows 7 usb/dvd download tool


my dvd drive is not reading the disc. so i guess some problem in drive or in os. currently i have pre-installed vista home premium 32 bit and planning to install windows 7 professional 32-bit.

Since my disk drive doesnt work so if i wiped my computer it would be stuck so i want to use USB/DVD tool to put the iso onto an external hard drive and boot it that way. so planning to boot windows 7 from usb device.

i have formatted my usb device with ntfs file system and it has 29Gb free space.

while running Windows 7 USB/DVD Download Tool at step 4 of 4 : creating bootable usb device
Status : we were unable to copy your files. Please check your USB device and the selected ISO file and try again.

why it is not able to copying my windows 7 files into usb device?

is there any other application where i can install windows 7 from usb device?

please reply soon.

Finally i found the solution to my own post and here is the solution for it. I hope it will help some other user who are facing the same problem. 

Sometimes if your USB stick has something in its MBR you might get the error
Windows 7 USB/DVD Download Tool error: We were unable to copy your files. Please check your USB device and the selected ISO file and try again.

You have to start command prompt as an Administrator (On Windows 7 that means right clicking the cmd and selecting Run as Administrator) and use the diskpart utility.

WARNING: Be careful to select the right drive or else your day won’t have a happy end because if you select the wrong drive you will lose all your data on this drive!

Instead of formatting the partition with FAT32, you can also use NTFS (like WUDT does), but then you need an extra step to make the drive bootable:

Bootsect.exe /nt60 X:

“X:” is the drive letter of your USB stick. Bootsect.exe can be found on the Windows 7 DVD in the boot folder. However, I can’t really recommend using NTFS. Some USB stick, at least, appeared to be slower with NTFS.

  1. Start command prompt as Administrator and type  diskpart 
  2. type  list disk
  3. type select disk  and number of your USB disk ( like select disk 1 )
  4. type  clean
  5. type  create partition primary
  6. type  select partition 1
  7. type  active
  8. type  format quick fs=fat32
  9. type  assign
  10. type exit  to exit the diskpart utility
  11. type exit  to close command prompt

Finally Bootable USB device created successfully.


Thanks to everyone and i am glad it solved each ones problem.

Please click on Helpful and Mark as Answer if your issue is solved.

Programming is like ****, One mistake and you have to support it for the rest of you life.

1248 people found this reply helpful

Was this reply helpful?


Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.


Question Info

Last updated September 20, 2021 Views 380,396 Applies to: