.NET Framework failed install due to "TRUST PROVIDER"

 I am having difficulty installing 4.7.1 and I mistakenly removed the previous version that was working but not updating properly. I get the following message ".NET Framework 4.7.1 has not been installed because: The form specified for the subject is not one supported or known by the specified trust provider." Any help would be appreciated.

the log file shows:

OS Version = 6.1.7601, SP = 1.0, Platform 2, Service Pack 1
OS Description = Win7 - x64 Service Pack 1
MSI = 5.0.7601.23593
Windows version = amd64_windowsfoundation_31bf3856ad364e35_6.1.7600.16385_none_5f2ecc1aaa4ac3b2.manifest
Windows servicing = 6.1.7601.23505
CommandLine = D:\f3cddb03ceeac3f1c414cb31\\Setup.exe /x86 /x64 /redist
TimeZone = Eastern Standard Time
Initial LCID = 1033
Using Simultaneous Download and Install mechanism
Operation: Installing
Package Name = Microsoft .NET Framework 4.7.1 Setup
Package Version = 4.7.02558
User Experience Data Collection Policy: AlwaysUploaded
Number of applicable items: 9
D:\f3cddb03ceeac3f1c414cb31\netfx_Full_x64.msi - Signature verification for file netfx_Full_x64.msi (D:\f3cddb03ceeac3f1c414cb31\netfx_Full_x64.msi) failed with error 0x800b0003 (The form specified for the subject is not one supported or known by the specified trust provider.)
No FileHash provided. Cannot perform FileHash verification for netfx_Full_x64.msi
File netfx_Full_x64.msi (D:\f3cddb03ceeac3f1c414cb31\netfx_Full_x64.msi), failed authentication. (Error = -2146762749). It is recommended that you delete this file and retry setup again.
Exe (D:\f3cddb03ceeac3f1c414cb31\SetupUtility.exe) succeeded.
Exe Log File: dd_SetupUtility.txt
ServiceControl operation succeeded!
ServiceControl operation succeeded!
Exe (D:\f3cddb03ceeac3f1c414cb31\SetupUtility.exe) succeeded.
Exe Log File: dd_SetupUtility.txt

Final Result: Installation failed with error code: (0x800B0003), "The form specified for the subject is not one supported or known by the specified trust provider. " (Elapsed time: 0 00:00:15).

Moved from: Windows / Windows 7 / Other Windows apps

 

Question Info


Last updated July 13, 2019 Views 8,050 Applies to:

Hi Anonymous11387,

We just like to isolate this issue that your having right now with your device. Have you tried for the meantime to disable your fire wall and turn off your antivirus when installing the program? Try these first and let us know the outcome.

Regards.

9 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.