"Only one instance of wusa.exe is allowed to run" error when trying to install a Windows Standalone Update package

I'm coming across this error when trying to run the Windows Standalone Update for Microsoft Virtual PC on my Windows 7 Professional machine.  Checking the event logs, I see the following message:

Windows update could not be installed because of error 2147944018 "Another installation is already in progress. Complete that installation before proceeding with this install." (Command line: ""C:\Windows\system32\wusa.exe" "C:\Users\dorseytm\Desktop\Windows6.1-KB958559-x86.msu" ")

I've searched, but cannot find any installation that's in progress.  I've rebooted serveral times, I've tried running CCleaner on the registry, stopping and starting the Windows Update service, but nothing has worked.

The file I'm trying to execute is  Windows6.1-KB958559-x86.msu.  Any help on this would be greatly appreciated.


Thanks.

 

Question Info


Last updated October 14, 2018 Views 73,091 Applies to:
Answer

tmdorsey76,
     A couple questions.  Is this error only happening with KB958830 or with any others?  What language is being run on the PC?

If you are comfortable using the Registy Editor, then look to see if this key exists:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\InProgress

If that key is there then copy it to your desktop first then delete that key. 

**Modifying REGISTRY settings incorrectly can cause serious problems that may prevent your computer from booting properly. Microsoft cannot guarantee that any problems resulting from the configuring of REGISTRY settings can be solved. Modifications of these settings are at your own risk.**


Mike

284 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.