Access Denied - Setting Owner and/or Permissions on Registry Key

I am on a Windows 7 Home Premium system that was upgraded from Vista.  Several weeks ago when attempting to install Symantec Network Access Control, I ran into problems where the install would rollback because of an access problem with the registry.  Since then I have read and attempted numerous fixes.  None have worked.  My current problem is that VCRedist_x64.exe also fails to install with registry access denied.  Some of the steps that I have attempted include those in Mark Michaelis' blog.  This includes performing them from Safe Mode.  I also have run secedit /configure /cfg  %windir%\inf\defltbase.inf /db defltbase.sdb /verbose /areas REGKEYS.  Still can't get around the error.  The log for secedit includes some access denied errors for machine\software\microsoft.  Not sure how they might relate.  I can find specify key/subkeys with Regedit that have the problem...but so far non of the suggestions to reset ownership/permissions work. 

In advance ... I appreciate any new thoughts and insights to this problem.
There must be some way to disable ALL security on the registry long enough to clean this mess up...
 

Question Info


Last updated October 9, 2018 Views 159,014 Applies to:
Answer
You must seize ownership of the subkeys before you can change any access rights!

183 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.