Question
17213 views

How to Restore correct permissions on Windows Search directories?

Robson1961 asked on

Windows 7 search is not working properly, even after rebuilding the searching database. Besides, it is rebuilding the database continuously, every day, without my permission thus causing the slowness of the system.

When I try to fix the problem, by using W7 Troubleshoot Search and Indexing tool at the Control Panel, I receive the following message at the end of the process:  Incorrect permissions on Windows Search directories  - (red cross) Not fixed.

It is followed by this statement:

“When permissions on the Windows Search data directories are set incorrectly, the search service might not be able to access or update the computer's search index. This can result in slow searches or incomplete search results.

Data directory permissions

Permissions on Windows Search data directory

AUTORIDADE NT\SISTEMA”

(Important note: I am running Windows 7 SP1 - Brazilian Portuguese Version an the message above are originally in BR Portuguese, of course).

Can someone help me on this? Thanks in advance.

Robson

35 people had this question

Abuse history


Most Helpful Reply
gguess2010 replied on

Microsoft has ready not tried to resolve this problem.  The answer is quite simple.  Local the folder <<C:\ProgramData\Microsoft\Search>>.  The owner and permissions have to be replaced on the entire directory tree.

 

Detail instructions to accomplish this: 
>Right click it,
>select properties,
>select Security Tab,
>Advanced button
>Owner Tab
>Edit
>Select/Add your user ID and select "Replace Owner on subcontainers and objects"
>Click OK
>  Back completely out of the properties
>Right click <<C:\ProgramData\Microsoft\Search>>
>select properties,
>select Security Tab,
>Advanced button
>Permissions Tag
>Permissions button
>Add button
>enter name, check name, and select, and OK
>Back in the Permissions window: Select "Included inheritable..."  and "Replace all child object permissions ..."
>  OK out of the properties panels

May require a reboot to restart indexing.  Be sure to recheck the <<C:\ProgramData\Microsoft\Search>> for permissions and ownership.  My corporate security settings reset this each day.   What fun.

8 people found this helpful

Abuse history


progress