Windows 7 deletes all system restore points on reboot

I did a clean install of Win7 about 3 1/2 weeks ago and have had no problems. 2 days ago I discovered that no system restore points were available. After spending many hours researching the issue, I've taken the following steps but none have helped:

  1. Completely uninstalled AVG and installed Microsoft Security Essentials.
  2. Tried turning off System Restore, rebooting, turning it back on.
  3. Checked the SR schedule in Task Scheduler, all seems fine. It creates restore points just fine, it just won't keep them on reboot.
  4. Scanned computer thoroughly with three different anti-malware programs, no problems found.
  5. Did a sfc /scannnow, no problems reported.

No, I'm not running a system with dual booting.

In Local Services, I have Volume Shadow Copy set to Automatic, but it's never started unless I manually start it. I don't know if that's normal or not, have been unable to find a clear answer.

In my event viewer I see many instances of these 2 errors for Volume Shadow Copy - event ID 22:

Volume Shadow Copy Service error: A critical component required by the Volume Shadow Copy service is not registered. This might happened if an error occurred during Windows setup or during installation of a Shadow Copy provider. The error returned from CoCreateInstance on class with CLSID {e579ab5f-1cc4-44b4-bed9-de0991ff0623} and Name IVssCoordinatorEx2 is [0x80040154, Class not registered
].

and event ID 8193:

Volume Shadow Copy Service error: Unexpected error calling routine CoCreateInstance.  hr = 0x80040154, Class not registered.

Please help me - I need to know what the next step(s) should be.

 

Question Info


Last updated November 2, 2018 Views 134,267 Applies to:
Answer

I had the same problem  - System Restore points were being deleted after a reboot, and Volsnap errors were logged in the System event log. Here's how I fixed it:

1: Open a command prompt

2: Type Vssadmin list shadowstorage

3: Take note of what the shadow storage allocation is on the drive you're having issues with, in my case it was C: and the allocation was 18GB.

4: Change the allocation by using the Vssadmin command, syntax: vssadmin resize shadowstorage /On=C: /For=C: /Maxsize=1G (where Maxsize=the amount of disk space you've allocated to System Restore points. In my case it was 20 GB

5: In the case of the C: drive, the syntax would be VSSAdmin resize shadowstorage /On=C: /For=C: /Maxsize =20G

This worked for me, after increasing the size and rebooting my restore points were still intact and no longer being deleted.

 Rgds, El-Vee

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.