Windows 7 cannot be loaded with SATA RAID drives

Hi, the problem is a bit complicated and lengthy here but I  hope someone can help me out.

 

Background information:

 

I am running Windows 7 64-bit Home Premium. I have two SATA harddisks and they are in RAID 1. I installed Windows 7 in these RAID'ed HDDs and placed some important files, e.g. docs, images, videos.

 

Event log:

 

1) A few days ago I found my mother board (ASUS) BIOS was quite out-of-date and I updated it. Then from ASUS website I downloaded the latest Intel Rapid Storage Technology (RST) drivers but when I tried to update, it failed by saying "minimum system requirement not met". And the original Intel RST was not working.

 

2) In BIOS configuration I found the SATA status is set to IDE. At this point, everything seemed still normal - at least I could boot up Windows 7 and access all of the files.

 

3) I wondered why Intel RST was not working and whether the RAID configuration was still in force, then in BIOS configuration, I changed SATA status to RAID. Then this time I couldn't load Windows 7 but entered Startup Repair.

 

4) In Startup Repair, it diagnosed and tried to fix the problem but failed. The error message is "No OS found on disk", with 0x490.

 

5) Then in BIOS configuration, I changed back to IDE. But still I couldn't load Windows 7 but only entered Startup Repair. I tried System Restore but it said I didn't have an image to restore from.

 

6) After reading some support threads, I went to Command Prompt and tried Bootrec /ScanOS and it said there is no recognized OS version. Then I tried Bootrec /FixMBR and /FixBoot, although it said the operation was successfule, it still couldn't load Windows 7.

 

7) In Command Prompt of Startup Repair, I tried to DIR both HDDs and it bounced me lots of "files are unreadable" error messages. Then I did a CHKDSK /R on the drives. It seemed to have fix harddisk A but many files are lost! Harddisk B still has many files not readable.

 

8) After the CHKDSK /R operation, however, I still couldn't load Windows 7. This time the the error message was "incompatible OS version".

 

I really don't know what should be the next step. And, my priority now is to have my personal docs, images, videos back. How can I migrate those files out? And, if there is any way to recover my lost or unreadable files? Many thank for your great advices!!!

 

Regards, Eric

Hi Eric,

 

I would request you to post the same question in the following TechNet link, as they are better equipped to handle this issue.

 

http://social.technet.microsoft.com/Forums/en-US/category/w7itpro

 

If you have any further questions regarding Windows operating systems, reach out to us on this forum. We are happy to assist you.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated December 24, 2017 Views 136 Applies to: