Windows 7 64-bit does not boot with AHCI Enabled (Barracuda 7200.12)

Windows 7 Ultimate 62-bit does not even boot if I enabled AHCI mode (in BIOS) for my Barracuda 7200.12 SATA Drive.  I have to disconnect the drive (unplugging the cable), then only I see the BIOS. I then go in and change the SATA Drive mode from AHCI to IDE. Only then Windows can boot.

I have the latest version of the BIOS and the latest firmware for my SATA Drive. I looked up both on the internet and this forum and this looked like a known issue for 7200.11 version of the drive but NOTHING shows up for my version (7200.12)

Would really love some help here as this is quite frustrating. Is this drive not compatible with Windows 7 64-bit? Is there another drive that Windows officially supports?

Answer
Answer

Hi TDK650M,

 

For your information, Seagate Barracuda7200.12SATA 3Gb/s 500GB Internal Hard Drive is compatible with Windows 7 32 bit and with Windows 7 64 bit edition. The link below has the information.

 

Windows 7 Compatibility Center:Seagate Barracuda7200.12 SATA 3Gb/s 500GB Internal Hard Drive

 

The reason why Windows 7 doesn’t boot when you enable AHCI mode in BIOS is because Windows 7 disables the AHCI drivers during the installation.

 

I would suggest you to follow the steps mentioned below in order to enable AHCI in Windows System Registry.

 

Important The steps mentioned below tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:

 

How to back up and restore the registry in Windows

www.support.microsoft.com/kb/322756  

 

1.    In the Windows start menu search box type "regedit" (without the quotes) then right click the entry and click "Run as Administrator".

2.    Enter your user credentials for the User Account Control prompt and then click Yes to open regedit.

3.    In the Registry Editor window, navigate to  HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services

4.    In the left pane click "msahci"

5.    In the right pane, right click on "start” and then click "modify".

6.    In the window that opens, change the value to "0" and click OK.

7.    Close the registry editor by clicking on File menu on the top and then Close.

 

Now you'll need to restart your computer and then get into the System BIOS. Change the mode from IDE (Integrated Drive Electronics) to AHCI (Advanced Host Controller Interface). Save the changes and exit.

 

Windows will now install the drivers for your AHCI. You would need to restart one final time to finish the process after the drivers are installed.

 

Hope this information is helpful and let me know if this worked.

Mouneshwar R – Microsoft Support

--------------------------------------------------------------------------------------------------------------------

Visit our Microsoft Answers Feedback Forum and let us know what you think


[If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]

22 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated November 23, 2020 Views 62,967 Applies to: