• July 17, 2017
    Announcement: New site design for Microsoft Community

    In July, Microsoft will roll out the first of ongoing site improvements aimed to modernize Microsoft Community and help customers get the most out of their community experience.

    • During the roll out period, you may see the old or new site design depending on your location

    • We expect the roll out to finish by 31 July

    Note: Past private message conversations will not move to the new site design. Please save any private messages you would like to keep.

     Learn more about the upcoming site improvements in this thread.

    Thank you for being part of Microsoft Community!

 
Question
Applies to
12959 views

Removing a rogue registry key

Robert Grant asked on

I have a registry key that I cannot delete.  If I try to click on or delete the key, I get the error "An error is preventing this key from being opened.  Details: The system cannot find the file specified."  If I try to delete the branch, I get a generic "error while deleting key"

The key is HKEY_USERS\...\Software\Adobe\Common\10\Sites\Software\SecuROM\License information

Bckground: In trying to move DreamWeaver site information over from a dead box, I inadvertently imported the entire Software registry branch from the old box into the DreamWeaver branch on the new W7 box.  I was able to remove all the extraneous information except for this key.  This key seems to be stopping me from retaining site information in DW, as any sites I create are lost when I close DW.

I've tried taking ownership of the key and branch in regedit but just get the same error that it doesn't exist.  I've contacted Securom tech support and they suggested using RegDelNull (http://technet.microsoft.com/en-us/sysinternals/bb897448.aspx), but that was also unsuccessful).  Any other ideas for aggessively removing the rogue key?

Thanks

12 people had this question

Abuse history


The answered status icon Answer
Funky D replied on

Sorry to dig up this thread, but I had the same question as OP and this topic was one of the first on a google search that brought up very little info.  After some more searching, I was finally able to find a solution in this KB article:

http://support.microsoft.com/kb/2021860

 

I figured I'd post the solution here for others who are googling for an answer and got frustrated when they found this thread didn't really lead anywhere.

 

You'll want to download RegDelNull from here:

http://technet.microsoft.com/en-us/sysinternals/bb897448

 

Extract to a location that is easy to get to, i.e. C:\Temp

 

Open a command prompt as administrator (All Programs --> Accessories --> Shift-Click on "Command Prompt", Run As Administrator)

 

Navigate to the directory where you saved RegDelNull (i.e. type cd \ <enter>, cd temp <enter>)

 

In the OP question, where the SecuROM key is in the HKEY_USERS, you'll want to type regdelnull hku -s <enter>.  You should then get a prompt to delete the key.  Press Y and the key will be deleted.

 

If the above doesn't work, you may need to load Windows in Safe Mode and log into the administrator account.  If the reg key is in your local account (HKCU), you may need to load the NTUSER.DAT hive and run regdelnull against hkcu instead.  I'm not going to get into that, but hopefully I provided enough if needed.

6 people found this helpful

Abuse history


progress