Netbook won't start - Safe mode stops at classpnp.sys

My MSI u130 windows 7 starter does not start, merely gets to the loading screen (where you see the green flash going above the words microsoft corporation).
Launch startup repair shows a white bar and the message windows is loading files before going to the loading screen.
Launching os recovery does the same as above.
Using safe mode hangs at 'classpnp.sys'.
A variety of other safe mode options stop at 'classpnp.sys'.
I downloaded the windows 7 recovery disk iso and put it on a USB. After some problem with "NTLDR is missing Press Ctrl Alt Del to restart" downloaded bootsect.exe, used that, then got a message windows is loading files and a white loading which, which, when complete, put me back tot he normal windows loading screen, zero other activity.

Have tried to boot to a linux system off a usb to replace the classpnp.sys file with one I found on this xp machine, but can't get linux to start off the usb.

So any ideas? With my main laptop with my wife I desperately need this netbook working, not least because it has office 2007 on it.

Its fixed! Well the sd card reader still doesn't work but windows 7 is off again.
The win 7 repair disk cd didn't work, just got the 'NTLDR is missing' error.
So as my last gasp I formatted a usb drive to NTFS and loaded Knoppix version 6.2 using UNetbootin, which booted the PC. Then I renamed the old classpnp.sys to classpnp.sys.bak and copied the one from my xp machine over. The PC then started, went to recovery, took 15 minutes thinking about what to do then started fine.

The result is one happy daughter.

Now to figure out how to make the Fn and Ctrl keys be the right way round...

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.


Question Info

Last updated May 15, 2018 Views 7,199 Applies to: