Missing East Asian characters on Windows 7 (Spanish edition; used to work fine)

I've had a problem with the visualisation of East Asian characters (both Chinese and Japanese) for several months now, and I haven't been able to find any fix for this yet. I am using a Spanish-language version of Windows 7 Professional. Basically, both with my previous version of WindowsVista and with the current version of Windows 7 when I originally installed it, I had no problem viewing Chinese characters in file names in the file explorer windows. I could also use Notepad to open Chinese text files or type Chinese (I have installed the Microsoft pinyin IME). Other programs like Notepad++ also worked fine. But after using Windows 7 for some time, Chinese characters all of a sudden became square blocks. This doesn't affect all programs, but it seems to affect the more basic text rendering capabilities, not just the file names. For example, on Internet Explorer and Google Chrome I can see East Asian characters on web pages, but not on the tab names or the bookmarks menu (all the bookmarks I have in Chinese now appear as square blocks). Besides, if I open up Notepad, save a new file with the UTF-8 or UTF-16 ("Unicode") encodings, I can type Chinese by selecting the right characters on the IME window, but the text is rendered as square blocks on the Notepad window (the same happens on Notepad++). It is clearly a font display problem because if I add a few HTML tags to turn the file into a web page and load it using a web browser, the Chinese text is correct.

Now I remember this happened to me for the first time last Summer (around July 2011) and I think it was after a Windows update. I may be wrong about the dates, though, but I am completely sure that Chinese characters would render just fine on Windows 7 before. I remember briefly installing the Google pinyin IME, so I don't know if it could be related to that. I don't think so, but I mention it just in case.

The only progress I ever made was a few weeks ago, when I managed to fix the problem temporarily by going to Control Panel -> Fonts -> Font settings and unchecking the "Hide fonts based on language settings" checkbox, which was checked. But the fix didn't last long. After a reboot the Asian characters reverted back to square blocks even though the "Hide fonts based on language settings" checkbox has stayed unchecked.

After a few searches on the web I've found a few forum questions where people ask about this problem, but most of the answers mention unrelated things like changing the whole OS language to Chinese (which you can only do on Ultimate) or changing the default language for non-Unicode programs to Chinese. I don't want any of that. I just want to keep the user interface of my Windows 7 OS in Spanish and be able to view Chinese characters on file explorer windows, the desktop, Notepad, Notepad++ and the IE and Google Chrome tabs and toolbars. All this used to work fine with the original installation of Windows 7 before the updates or whatever wreaked havoc on the fonts. Does anybody have any ideas what I could do to restore the correct rendering of East Asian characters?
Answer
Answer

Hello,

 

If the problem came back with a reboot, then let;s attempt clean boot troubleshooting:

How to troubleshoot a problem by performing a clean boot in Windows Vista or in Windows 7

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Answer
G33k_2012,  are you in service pack 1 ??    I'm quite sure this problem came in after service pack 1.

So far I found the following workaround almost can temporarily fix the problem, as soon as I see the square box for chinese text I do 

either 

1) delete fntcache.dat in windows/system32

or 

2) open windows/fonts directory and let all font to load

then reboot.


OP of this thread suggested to do a clean boot which will also work, but I think above workaround is a lot simplier

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated December 24, 2017 Views 2,916 Applies to: