Fix boot entry of/install Startup Repair/System Recovery environment?

I'll start off by saying I've posted a related question over at SuperUser: http://superuser.com/questions/421467/repair-startup-repair

However, I feel a more Windows-centric (and more official) forum may be a better place to ask.

I've managed to corrupt my BCD by (accidentally) setting my RAID array to IDE mode (well, more an accidental CMOS reset and not realising until Windows tried to boot). After switching RAID on I managed to repair the BCD manually using my (OEM/SP1) installation disc and `bcdedit`. Specifically, I had to change `device` and `osdevice` from `unknown` to the correct partition(s) and then run startup repair off the DVD. The Windows installation is working perfectly, but I've lost all System Restore points.

The problem is, Startup Repair is... broken. The boot option is there, but it gives the same `The boot selection failed because a required device is inaccessible.` error (`0xc000000e`) as the normal start did before I manually edited the BCD. If someone could point me in the direction of the startup repair files/boot data or, better, give me instructions on resetting `osdevice` and/or `device` as I did for the normal boot, that would be great.

Alternatively, I've also completely rebuilt my BCD (renamed \Boot\BCD and then run bootrec /rebuildbcd from the DVD). When booting off this, Startup Repair does not appear as a boot option and `bcdedit` shows some recovery fields (presumably populated with volume GUIDs or something) are missing. It's essentially a Windows installation without startup repair. If someone could tell me how I can install Startup Repair on my hard drive as it originally was, without reinstalling Windows, that would be great too. An upgrade install seems to be an option, but that may break come programs/services, which is what I'm trying to avoid.
Answer
Answer
There we go, fixed it. While this would be theoretically fixable through a registry editor, I used Visual BCD Editor. EasyBCD and bcdedit.exe both did not show the Recovery Environment boot option, but that program did - and the text names are a lot friendlier than the GUID list in the registry. I went for fixing the corrupted store rather than adding to the clean one, since the corrupted one has quite a few other possibly important entries.

I've listed the complete steps, along with screenshots, in a answer to that SuperUser question I linked to earlier. The possibility to embed images made explaining much.

Basically, I just reset the partition paths to the correct partition, as I originally did for the primary boot option.

Hmm.. I can't seem to mark this post as the answer to my question. Well, that's stupid, I did kind of solve it myself.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated June 17, 2019 Views 17,125 Applies to: