How to fix Blue Screen error (BSOD) caused by NetIO.sys on Windows 7 Ultimate x64

Hi! I have a real problem going on with my machine. I have a Dell Studio 1558 with 8GB of RAM, Intel i7 Processor Q 840 @ 1.87 GHz (8M cache), 64-bit Operating System and ATI Mobility Radeon HD 5470 1 GB Graphic Card with Windows 7 Ultimate edition.

Now, my computer use get shut down automatically with a blue screen error message. Initially I didn't have any idea what could be the cause of the problem, so I had Dell engineers changed the motherboard, cooling fan and thermal pad of the machine thinking that it might be some hardware issue but it didn't really help. I even installed a new fresh copy of Windows, formatting the whole HDD and that even didn't go for a penny So, after all the research work, I came to know about "Windbg" tool. I tried to debug the files that were left into the "C:\Windows\Minidump" folder.

(NOTE- I've absorved that my computers only gets shutdown only after I try running Utorrent. It happens after sometime, when I try runing Utorrent, which is P2P sowtware for downloading movies, songs, software etc).

So, here is what I got as a result:-


Microsoft (R) Windows Debugger Version 6.12.0002.633 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.


Loading Dump File [C:\Windows\Minidump\032711-14539-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

WARNING: Whitespace at end of path element
Symbol search path is: http://msdl.microsoft.com/download/symbols

Executable search path is:
Windows 7 Kernel Version 7601 (Service Pack 1) MP (8 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 7601.17514.amd64fre.win7sp1_rtm.101119-1850
Machine Name:
Kernel base = 0xfffff800`03200000 PsLoadedModuleList = 0xfffff800`03445e90
Debug session time: Sun Mar 27 01:46:00.691 2011 (UTC + 5:30)
System Uptime: 0 days 0:47:37.653
Loading Kernel Symbols
...............................................................
................................................................
................................................................
.
Loading User Symbols
Loading unloaded module list
.........
*******************************************************************************
* *
* Bugcheck Analysis *
* *
*******************************************************************************

Use !analyze -v to get detailed debugging information.

BugCheck D1, {28, 2, 0, fffff880015b1b2d}

Probably caused by : NETIO.SYS ( NETIO!RtlCopyBufferToMdl+1d )

Followup: MachineOwner
---------

2: kd> !analyze -v
*******************************************************************************
* *
* Bugcheck Analysis *
* *
*******************************************************************************

DRIVER_IRQL_NOT_LESS_OR_EQUAL (d1)
An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high. This is usually
caused by drivers using improper addresses.
If kernel debugger is available get stack backtrace.
Arguments:
Arg1: 0000000000000028, memory referenced
Arg2: 0000000000000002, IRQL
Arg3: 0000000000000000, value 0 = read operation, 1 = write operation
Arg4: fffff880015b1b2d, address which referenced memory

Debugging Details:
------------------


READ_ADDRESS: GetPointerFromAddress: unable to read from fffff800034b10e8
0000000000000028

CURRENT_IRQL: 2

FAULTING_IP:
NETIO!RtlCopyBufferToMdl+1d
fffff880`015b1b2d 448b5228 mov r10d,dword ptr [rdx+28h]

CUSTOMER_CRASH_COUNT: 1

DEFAULT_BUCKET_ID: VISTA_DRIVER_FAULT

BUGCHECK_STR: 0xD1

PROCESS_NAME: System

TRAP_FRAME: fffff8800335a620 -- (.trap 0xfffff8800335a620)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=fffff8800335a840 rbx=0000000000000000 rcx=0000000000000000
rdx=0000000000000000 rsi=0000000000000000 rdi=0000000000000000
rip=fffff880015b1b2d rsp=fffff8800335a7b0 rbp=fffff8800335a8e0
r8=00000000ffffffbc r9=0000000000000044 r10=0000000000000000
r11=fffffa8007945330 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0 nv up ei pl zr na po nc
NETIO!RtlCopyBufferToMdl+0x1d:
fffff880`015b1b2d 448b5228 mov r10d,dword ptr [rdx+28h] ds:00000000`00000028=????????
Resetting default scope

LAST_CONTROL_TRANSFER: from fffff8000327fbe9 to fffff80003280640

STACK_TEXT:
fffff880`0335a4d8 fffff800`0327fbe9 : 00000000`0000000a 00000000`00000028 00000000`00000002 00000000`00000000 : nt!KeBugCheckEx
fffff880`0335a4e0 fffff800`0327e860 : fffffa80`08ba73c0 fffff880`0172edd2 00000000`00000001 00000000`00000044 : nt!KiBugCheckDispatch+0x69
fffff880`0335a620 fffff880`015b1b2d : fffffa80`0779d140 00000000`0000005e fffffa80`07c8a940 00000000`000021d0 : nt!KiPageFault+0x260
fffff880`0335a7b0 fffff880`017725ec : 00000000`00000000 fffff880`01741376 00000000`00000001 fffffa80`00000004 : NETIO!RtlCopyBufferToMdl+0x1d
fffff880`0335a810 fffff880`0173e963 : fffffa80`07945330 00000000`00000001 fffffa80`0779d140 00000000`00000000 : tcpip! ?? ::FNODOBFM::`string'+0x1d6ef
fffff880`0335a880 fffff880`0172cd54 : fffffa80`06f5c8e0 00000000`0000a6fc fffff880`0335ad78 fffffa80`07d6d000 : tcpip!TcpTcbCarefulDatagram+0x543
fffff880`0335aa30 fffff880`0172b5ea : fffffa80`07c45980 fffff880`01723a00 fffffa80`07c046a0 00000000`00000000 : tcpip!TcpTcbReceive+0x724
fffff880`0335ac20 fffff880`0172d2ab : fffffa80`07e63112 fffffa80`07d6d000 00000000`00000000 fffff880`0335af00 : tcpip!TcpMatchReceive+0x1fa
fffff880`0335ad70 fffff880`01724137 : fffffa80`07c45980 fffffa80`07c3a6fc fffffa80`00007636 00000000`00007636 : tcpip!TcpPreValidatedReceive+0x36b
fffff880`0335ae40 fffff880`01723caa : 00000000`00000000 fffff880`01833800 fffff880`0335b000 fffff800`033abfbd : tcpip!IppDeliverListToProtocol+0x97
fffff880`0335af00 fffff880`017232a9 : fffff8a0`0b0a3610 00000000`c0000503 fffff880`0335b0d0 fffff880`0335aff0 : tcpip!IppProcessDeliverList+0x5a
fffff880`0335afa0 fffff880`01720fff : fffff880`01833800 fffffa80`07e63102 fffff880`01833800 fffff880`01833800 : tcpip!IppReceiveHeaderBatch+0x23a
fffff880`0335b080 fffff880`017205f2 : fffffa80`08460f50 00000000`00000000 fffffa80`08460000 00020006`00000001 : tcpip!IpFlcReceivePackets+0x64f
fffff880`0335b280 fffff880`0179475a : 00000000`00000240 00000000`00000011 fffffa80`08460010 fffff880`0335b4c0 : tcpip!FlpReceiveNonPreValidatedNetBufferListChain+0x2b2
fffff880`0335b360 fffff800`0328d078 : fffff8a0`00004ac0 fffff880`0335b400 fffffa80`06dcbb60 00000000`00000001 : tcpip! ?? ::FNODOBFM::`string'+0x56e52
fffff880`0335b3b0 fffff880`01720152 : fffff880`0171f9b0 fffff880`00000040 fffff8a0`0cb33400 00000000`00000001 : nt!KeExpandKernelStackAndCalloutEx+0xd8
fffff880`0335b490 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : tcpip!FlReceiveNetBufferListChain+0xb2


STACK_COMMAND: kb

FOLLOWUP_IP:
NETIO!RtlCopyBufferToMdl+1d
fffff880`015b1b2d 448b5228 mov r10d,dword ptr [rdx+28h]

SYMBOL_STACK_INDEX: 3

SYMBOL_NAME: NETIO!RtlCopyBufferToMdl+1d

FOLLOWUP_NAME: MachineOwner

MODULE_NAME: NETIO

IMAGE_NAME: NETIO.SYS

DEBUG_FLR_IMAGE_TIMESTAMP: 4ce79381

FAILURE_BUCKET_ID: X64_0xD1_NETIO!RtlCopyBufferToMdl+1d

BUCKET_ID: X64_0xD1_NETIO!RtlCopyBufferToMdl+1d

Followup: MachineOwner
---------

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------

I came across a form http://social.technet.microsoft.com/Forums/en-US/w7itprogeneral/thread/77b2201a-1848-4164-a2c7-3ebbdb1e3020 Now if, you see here a member named "DestructoBun" almost had similar problem and in reply to that, member named "Mr X" replied to with http://support.microsoft.com/kb/979278/en as a MS Hotfix. I even tried that which is a zip file. I tried unzippng this one and tried to run it but it says "The Update is not applicable to your computer". I don't understand WHY??????

I really didn't have any shot left to try. If anyone can please help me, I'll deeply appreciate it.

Thank's

Aman Gill.

P.S- Especially, I'm counting on Mr. X and Andre Ziegler for help :-)

(NOTE- I've absorved that my computers only gets shutdown only after I try running Utorrent. It happens after sometime, when I try runing Utorrent, which is P2P sowtware for downloading movies, songs, software etc).

 

Question Info


Last updated March 9, 2020 Views 45,810 Applies to:
Answer
Answer
Hi Everyone,

My problem has gone.I'm just uninstall Mcafee and Install again.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.