How do I repair windows7 sp1 that gives me an error 7001

I have a HP Pavilian laptop running windows 7 sp1 and my profile does not function.  Other accounts are fine and my profile works in safe mode.  I get the error 7001 every time I try to start a program or do anything.  I have tried system restore an it will not complete but hangs up.   I tried my system repair disk with the same results I do not have a recent backup copy.  I believe the problem has to do with a dependancy on the COM file for the  windows server to run.  How do I fix this or how can I reload windows 7 without buying it.  Windows 7 came preloaded when I bought the laptop.
|
Answer
Answer

Hi,

 

Welcome to Microsoft Community and thank you for the post.

 


It looks that your account profile does not work properly in Windows 7 as you are unable to use the programs in this profile. I appreciate the efforts which you have put to get the issue resolved.

 

Follow the troubleshooting methods given here.

 

Method 1: Boot the computer to safe mode and perform the below mentioned steps.

 

Note: This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to know How to back up and restore the registry in Windows

 

http://windows.microsoft.com/en-IN/windows7/Back-up-the-registry


Safe mode starts Windows with a limited set of files and drivers. Startup  programs don't run in safe mode, and only the basic drivers needed to start Windows are installed.

 

http://windows.microsoft.com/en-IN/windows7/Start-your-computer-in-safe-mode

 

After you boot to safe mode perform the steps given here.

 

a) Open Device Manager.
b) On the View menu, click to select the Show hidden devices check box.
c) Double-click Non-Plug and Play Drivers.
d) Double-click NetBIOS over Tcpip.
e) In the Device usage box, click Use this device (enable).

 

When you restart the system, the server may take longer to restart. If this behavior occurs, go to the following registry key:


HKey_Local_Machine/System/CurrentControlSet/Services/Netlogon/DependOnService

 

Double-click DependOnService and in the multi-string editor add the following value (if it is not already present):

 

LanmanServer

 

 

Method 2: Place the computer in Clean boot and check for the issue.


Perform a clean boot to check if any third party application is causing the issue, as clean boot helps in eliminating software conflicts. Follow these steps given in the link below to start the computer in clean boot.

 

http://support.microsoft.com/kb/929135


Note: Please follow the Step 3 after you are done with all the steps to Reset the computer to start as usual.

 

I hope this resolves your issue, please write to us if you have any other Microsoft issue related to Windows.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated May 4, 2018 Views 706 Applies to: