Question

Q: 'Fatal error C0000034' on boot after Service Pack 1 for 64-bit systems install This thread is locked from future replies

Hi there,

I installed Windows 7 Service Pack 1 for 64-bit system on my laptop after it appeared on Windows Update. The install seemed to go alright, however, when I restarted the computer at the prompt of Windows Update, it gets as far as the Starting Windows screen, before throwing 'Fatal Error C0000034 applying update operation 282 of 114599 (_00000...)'

At this point, the startup sequence hangs and gos no further. I restarted again by switching off at the mains, and this time was prompted to run Startup Repair. I tried this, however the Startup Repair program hung (I left it for several hours with apparently no effect). I then proceeded to try the following things:

-Boot in Safe Mode
This led to the startup to hang at the 'Loaded: CLASSPNP.SYS', 'Please wait...' stage. Again, left for several hours, no progress.

- Run the recovery CD to restore from a System Restore point.
The program hung at the restoring system stage - again, left for several hours, nothing happens.

- On advice from google, I tried using the recovery console to run DISM /image:D:\ /cleanup-image /revertpendingactions (I should mention that the recovery CD seems to think my windows install is now at D rather than C)
This led to an error attached at http://cid-78779374d6b6f1f3.office.live.com/self.aspx/.Public/dism.log

- Booting from last known good configuration
This just resulted in the same error as when I boot it normally

I haven't tried a complete system reinstall, as ideally I'd like to keep my files...

Any help would be greatly appreciated.

Sam

 

System Specs:

Windows Home Premium x64
Sony VAIO VPCEB2C5E Intel(R) Core(TM) i5 CPU M 520  @ 2.40GHz
4Gb RAM
Samsung HM321HI 500Gb HDD
ATI Radeon HD 5600 series graphics

Alsi uploaded CBS.log: http://cid-78779374d6b6f1f3.office.live.com/self.aspx/.Public/CBS.log
And poqexec.log: http://cid-78779374d6b6f1f3.office.live.com/self.aspx/.Public/poqexec.log
Don't know if they'll be useful or not.

Answer

A:

Okay, after much searching of Google, I found an answer that worked for me, my computer is now fixed without having to reinstall the OS. Solution courtesy of Aran, was found athttp://social.technet.microsoft.com/Forums/en-US/itprovistasp/thread/4491fe25-be44-430e-a384-fb58c5da5ad0/

It essentially involves doing a manual system restore.

- Open the recovery console

- Change working directory to whatever the root folder of the Windows install is (might be D: or some other letter for some people):

cd /d C:\windows\system32\config

Rename the following files by typing the following:

ren default default.old
ren sam sam.old
ren security security.old
ren software software.old
ren system system.old


- Change the working directory:

cd regback

- Copy the files from this directory to the previous directory as follows:

copy default c:\windows\system32\config
copy sam c:\windows\system32\config
copy security c:\windows\system32\config
copy software c:\windows\system32\config
copy system c:\windows\system32\config

- Having done this, I restarted my computer, and it booted all the way with no errors. However, it seemed somewhat unstable, so I booted into Safe Mode and ran CHKDSK (chkdsk /B) and conducted a normal system restore to before the service pack install using the normal method. To fix remaining problems, I ran sfc /scannow. My computer now seems to be running as well as ever.

Hope this helps,

Sam

Did this solve your problem?

Sorry this didn't help.

34 people were helped by this reply



 
Question Info

Views: 65157 Last updated: February 15, 2018 Applies to: