api-ms-win-core-libraryloader-l1-1-1.ddl is missing

Hi,

When trying to ugrade the os i get the following error message:

the program cannont start because api-ms-win-core-libraryloader-l1-1-1.ddl is missing from your computer. Try reinstalling the program to fix this problem, anyone have any ideas what this is??

Thanks

 
Question Info

Last updated August 15, 2018 Views 30,660 Applies to:
Answer

I saw the following from a searching around, the one below seems to explain the issue and a solution.  I did a backup of the file in question before over-writing.  It worked and allowed the installation to continue; my system is a Toshiba AMD laptop with Win 7.  

"Lots of people having this problem, myself included. Looks like api-ms-win-core-libraryloader-l1-1-1.dll is a Windows 8 kernel dll (1-1-0 is the version on Windows 7).

Somebody at MS screwed up the updater on the website, so we will probably just have to wait until they fix the issue.

Edit: A few minutes ago, someone at the linked forum suggested:

"Replace C:\Windows10Upgrade\wimgapi.dll with the one from C:\Windows\System32\wimgapi.dll"

I haven't tried this yet but I'm about to. I'll let you know if it works.

Edit 2: The suggestion appears to fix the issue. Update to Windows 10 in progress."

This came from the following REDDIT thread for citing:

https://www.reddit.com/r/windows/comments/7kwqqd/so_how_to_fix_the/

370 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.