Q: Windows 7 x64 WMP video playback freezes randomly for 3-4 minutes before resuming This thread is locked from future replies

Setup: Windows 7 Ultimate x64 clean install, Asus M5W DH Deluxe MoBo, Intel dual core 6420 2.13GHz, 4MB RAM, 2 Seagate Barracuda hard disks 0.5 & 1.5TB, NVIDIA GeForce 8800 GTX 768MB (latest x64 driver 195.62)

When I play videos (mostly DVDs or legal ripped DVDs), playback will sometime freeze my whole system for 3 to 4 minutes (always the same duration). Sometimes I can play a whole movie without any freeze, at other times it can freeze as early as 10 or 20 minutes into the movie, or as late as 1h30m after the start.

I use mostly built-in WMP12 for playback, but I noticed the same behavior with VLC or KMP players. It also happened once with the Miro player, and it also happens when playing WMAs on WMP.
I disabled all other applications or unnecessary services at some stage, to no avail. This machine has a dual boot with Vista Ultimate x32 on the smaller disk, but the same playbacks work just fine.

There is absolutely no error in any event log, and I really wonder why this should happen only to Windows 7 (x64?).

How can I debug this, and how can I fix it?
I am starting a new topic for this, as other similar topics do not seem relevant to these symptoms.

The weird thing is that the system always resumes after that 3-4 minutes freeze. The only thing is that the WMP playback seems to need to catch up with that delay, video and sound are kind of accelerated and not in sync for a while.
The system is partially responsive during the freeze too: I can see the play button bar when I hover with the mouse over the WMP window, the clock still counts the minutes in the taskbar, at least until I try to click on them: Then the donut mouse icon replaces the arrow, and the clock does not change time anymore.



Update: After 20 hours of continuous video playback in 3 different media players with mp4, avi, mkv files as well as ripped DVDs, I haven't experienced any more system freeze.
So it looks like the cause of the system freeze was indeed the Seagate 1.5TB disk defective firmware rev. SD17.
Upgrading the firmware to revision SD1B fixed it for me. Issue solved as far as I am concerned.
Thanks to Chris for putting me in the right track with the Seagate disk.

Did this solve your problem?

Sorry this didn't help.

Question Info

Views: 8,795 Last updated: March 16, 2018 Applies to: