Windows 7 - Resource and Performance Monitor

I have avast! Free Antivirus 5.0.594 installed into my home PC equipped with Windows 7 Home Premium (32-bit).  However, the Security Center has not recorded an anti-virus product as reported by the Resource and Performance Monitor (RPM).

As revealed by RPM, "the Security Center is unable to identify an active anti-virus application.  Either there is an anti-virus product valid or is not recognized".

Puzzled as avast! is one of the anti-virus products on the list recognized by Microsoft.

Is this a problem on Windows 7 Security Center?  Will there be any remedial action? 


A. Chung
Answer
Answer
See: "Reliability and Performance Monitor Not Detecting Anti-Virus Product in Windows 7/Vista".
Vincenzo Di Russo
Microsoft® MVP Windows Internet Explorer, Windows Desktop Experience & Security since 2003.
Moderator in the Microsoft Answers and TechNet Forums Italy
My MVP Profile: https://mvp.support.microsoft.com/profile/Vincenzo
---
Vincenzo Di Russo
Microsoft® MVP Windows Insider. Internet Explorer, Windows & Security Expert ~ since 2003
Moderator in the Microsoft Community and TechNet Forums

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Answer

I have avast! Free Antivirus 5.0.594 installed into my home PC equipped with Windows 7 Home Premium (32-bit).  However, the Security Center has not recorded an anti-virus product as reported by the Resource and Performance Monitor (RPM).

As revealed by RPM, "the Security Center is unable to identify an active anti-virus application.  Either there is an anti-virus product valid or is not recognized".

Puzzled as avast! is one of the anti-virus products on the list recognized by Microsoft.

Is this a problem on Windows 7 Security Center?  Will there be any remedial action? 


A. Chung

Hi A. Chung - Welcome to Microsoft Answers Community.

This has to do with Microsoft’s software (in code parts), and this means that the
Resource and Performance Monitor does NOT find the antivirus product, since
it is searching in the Windows Management Instrumentation (WMI).

Since, the Resource and Performance Monitor is searching using old query,
with old path.

Old Query:
root\SecurityCenter:SELECT * FROM AntiVirusProduct
New Query: root\SecurityCenter2:SELECT * FROM AntiVirusProduct

Now, since the case is about the older query, we end-up getting a message about that
the Security Center has not recorded an anti-virus product (See Image below).   


Figure 1: Resource and Performance Monitor failed generating correct data about the Security Center status.  

Try my Security Analyzer 1.0 (Beta) or my ITknowledge24 Security Center (Beta) today,
download them from my website: http://www.itknowledge24.com/

*Please post feedback regarding my software tools, or send me feedback by mail,
the address is in this POST: http://social.answers.microsoft.com/Forums/en-US/w7security/thread/543c448f-2914-4adf-8382-7166ac2ce647

I hope you find this information useful and if you need any further assistance,
please feel free to contact me and let me know.

I hope this information was helpful…

Have a nice day…

Best regards,
Fisnik


Itknowledge24.com - Follow me on Twitter: http://twitter.com/itknowledge24

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated November 12, 2019 Views 1,768 Applies to: