Windows 7: Cannot save files to C: even after making sure I'm administrator and I've checked 'allow' on all permissions.

Even after going through and making sure I'm set up as the administrator and checking all of the permissions I still get "A required privilege is not held by client" error message when I try to save any file to my C:. 

How do I turn off all of these weird privilege issues so I can save files where I want to (not in the library its trying to make me) and install programs?
 

Question Info


Last updated September 17, 2018 Views 229,718 Applies to:
Answer

Got the solution from one Site , as below it worked for me.

When Administrators Cannot Edit Files

Sometimes you are the admin (and the only user) of your home computer and yet, when you try to open some protected file, it says “access denied”. This is confusing because you are logged in as the super-user and if you don’t have access to all parts of the system, who else will?

The fix is simple though. I will illustrate this with Windows hosts file but you can apply the workaround to virtually all files that you are unable to read / edit in Windows because of permission problems.

Solution:

Step 1. Open your Windows start menu, search for the notepad application and then right click the notepad icon.

Step 2. Choose “Run as administrator” and then, while inside notepad, browse to folder (/windows/system32/drivers/etc) that contains the hosts file.

You can now edit and save that file in the same folder without any issues. To recap, the trick is that instead of directly opening a protected file in the associated application, you run the application first as an administrator and then open the file inside it.

131 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.