win 7: base filtering engine service missing (gone, does not exist):

Win-7 Home Premium: On Norton AV install I got an error message that said my Base Filtering Engine Service was missing.  I checked my services and the Base Filtering Engine Service is not there (gone, deleted, does not exist).  Problem may be due to "Win 7 Home Security 2012" virus which I've had problems with recently.

Can anyone tell me best, simplest way to get Base Filtering Engine back?  I'd rather not resort to restore or OS reinstall, but if that's the only way, then so be it.

Thanks in advance!

A.

 

 

 

Question Info


Last updated April 28, 2019 Views 44,209 Applies to:
Answer
Answer

Win-7 Home Premium: On Norton AV install I got an error message that said my Base Filtering Engine Service was missing.  I checked my services and the Base Filtering Engine Service is not there (gone, deleted, does not exist).  Problem may be due to "Win 7 Home Security 2012" virus which I've had problems with recently.

Can anyone tell me best, simplest way to get Base Filtering Engine back?  I'd rather not resort to restore or OS reinstall, but if that's the only way, then so be it.

Thanks in advance!

A.

 

 


Hi, welcome. Researching in the wild I have found a workaround that may fix it and as it was not official, I did not divulgate it here at Answers, a place by people with multiple levels of IT know-how. As I have found a similar answer confirmed by a Forum Moderator here, you can follow this link to see if it helps you, if not, be prepared to go into the restore or reinstall process. Good Luck and Regards. PS - Actually, there is not an easy and safe way to fix this so far.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.