when I try to delete some folders, an error message pops up saying "You require permission from SYSTEM to make changes to this file".

original title: Require permission from SYSTEM

I decided to do a clean install of the latest Windows 7 RC last night, and today went through and started to delete some programs from a seperate hard drive so I could reinstall them clean.  However when I try to delete some folders, an error message pops up saying "You require permission from SYSTEM to make changes to this file".  I am using an administrator account, but I simply can not delete the file.  I've tried going in and changing the owner to either my account or Administrators, close it, change the Security permissions to allow me to have Full Control, and then I can finally delete it.  The problem is, I have to do this for every file one by one in the folder, and I'm wondering if there's an easier way to go about this, or if I can access this SYSTEM user and simply delete them all from there.  Thanks for the help.

 

Question Info


Last updated December 13, 2019 Views 385,333 Applies to:
Answer
Answer

Hello, Xivios

You can change the permissions for folders (and subdirectories) by right clicking on the parent folder, choose Properties, go to the Security tab, click Advanced, go to the Owner tab, click Edit, select the new owner and check the Replace owner on subcontainers and objects and press Apply.

Let us know if this helps.


David
Microsoft Answers Support Engineer
Visit our Microsoft Answers Feedback Forum and let us know what you think.
-----
If you can't fix it with duct tape, you haven't used enough.

75 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Answer
Hi,

Not trying to resurrect old threads, but I'm gonna reply anyways since this thread came on top of the search results list when I searched for "you require permission from SYSTEM"; hopefully this'll help everybody.

Note: here, 'folder' as a subject refers to the folder that you want to delete.

Step 1: Get access to the built-in administrator account, which you can do by following these steps:
            a. Go to Control Panel > System and Security > Administrative Tools
            b. On the left panel, go to Local Users and Groups > Users; you should now see a list of users on your computer
            c. Right-click the Administrator account which shows up in the list and go to Properties
            d. Uncheck 'Account is Disabled' and confirm by pressing OK

Step 2: Log on to your newly-enabled administrator account

Step 3: Now we begin setting-up the security settings that will allow you to delete that folder that was (perhaps) once owned by SYSTEM:
            I'll make an assumption that you want to delete a folder and all its sub-folders along
            a. Right-click the folder
            b. Go to the Security tab on the top
            c. Click the Advanced button that's at the bottom

Step 4: The first part of setting-up the security settings is to set the owner of the folder:
            a. Go to the Owner tab on the top
            b. Click the Edit button that's at the bottom
            c. There should be a list of accounts to pick from to change ownership to, this is located under the label 'Change owner to:'
            d. The entry 'Administrator (YOURCOMPUTERNAME\Administrator)' should be there; if not then we have to add it into the list:
                - Click the 'Other users or groups...' button that's at the bottom
                - Under the label 'Enter the object name to select (examples):', there should be a text field that you can type in; type in 'Administrator' (without the quotes of course)
                - Click the 'Check Names' button that's on the right; 'Administrator (YOURCOMPUTERNAME\Administrator)' should now be there _by itself_; well if not, then you have to delete the line which does not represent the administrator account you're in right now
                - Confirm by pressing OK; it'll now appear on the list of accounts you can select from
            e. Now select 'Administrator (YOURCOMPUTERNAME\Administrator)' from that list
            f. Check 'Replace owner on subcontainers and objects' to propagate our change
            g. Press OK to confirm; a message should now pop-up, indicating that you have to re-open Properties. Do so by pressing on all the OK buttons you see

Step 5: Now that we've set the owner of the folder, we're still not done. There's one key step left which is to remove inheritable permissions:
            a. Repeat step 3 to get to re-open Properties and get to 'Advanced Security Settings'
            b. Go to the Permissions tab on the top
            c. Click the 'Change Permissions' button that's at the bottom
            d. At the bottom, there should be 2 checkboxes:
                - 'Include inheritable permissions from this object's parent': Un-check this; when you do so, you'll get a warning about parent settings not being able to propagate. Select 'Add'
                - 'Replace all child object permissions with inheritable permissions from this object': Check-this
            e. Confirm by pressing OK. Windows will warn you again this time; hit OK
            f. Confirm again by pressing OK; now you should arrive at Properties again

Now you should not have any warnings about SYSTEM not giving you permission while trying to perform actions on that folder.
All the checkboxes for changing permissions on accounts (Properties > Security > Edit) should now be enabled, and you can tinker around with it.

75 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.