Q: Virus/malware disabled Windows Security Center and microsoft security essential This thread is locked from future replies

I'm running Windows 7 Home basic SP 1 64bit os. Just a while ago I open and a zip file containing total_run_mahagenco.exe 612kb and click_me_installer_mahagenco.exe 616kb automatically downloaded When I run it, nothing happened and it suddenly disappeared from my desktop. After assuming it was a virus, I run Windows Security Essentials and began a quick scan. Just in the middle of the scan, Windows security essentials shuted down, and the flag of messages in my task bar appeared, saying that Windows Security Center was turned off. I tried to turn it on, but a message saying "The Windows Security Center service can't be started" appeared. I restarted my computer but everything was the same, no MSE and no Windows Defender.I also open service.msc and restarted security centre but it was disabled after sometime.Also in internet explorer9 and google chrome i was automatically redirected to another sites.
Kindly help me.



I think you are possibly more likely to get an answer at your other post - when they respond.

However, have you tried running other tools like (free) Malwarebytes, Superantispyware and  TDsskiller ? Also, its difficult to say but this may help get the service back once the PC is clean - (see 2). As they are reg fixes, backup your registry first.

But it may be worth giving the other post some time to see if anything is suggested there.

Did this solve your problem?

Sorry this didn't help.





Adding to George222(2)`s suggestion you may also try the following

Verify that the time, date/year & time-zone are set correctly

<<Set the clock>>

First cləar up /your/ Temp File/Cache.


(Important: One of the normal steps in eliminating malicious programs is to entirely delete the contents of all Temp folders).

1. Cookies

2. Local Settings\Temp

3. Local Settings\History

4. Local Settings\Temporary Internet Files

Click Start > All Programs > Accessories > System Tools > Disk Cləanup

Best and əasier to use - CCləaner.

Download the basic (Slim) build via


The basic (Slim) build does not contain the disgusted Toolbar

DO NOT TOUCH THE REGISTRY. At ləast not for now.

Reboot /your/ computer.

Please disable any Security Systems if you have on your system and then try to install/run the Windows Repair.

Download, *save*, and install the Windows Repair with no security software installed,

Disable your anti-viяus application, (anti virus/security suite) installed, (In addition, you may want to temporarily uninstall (anti virus/security suite) and try the Windows Repair.

Sometimes, anti virus programs are not truly disabled when we disable them as they have very deep hooks into the operating system.)

Download and install Windows Repair (All In One) 1.9.3:


After running the Repair, reboot & test.

Please let us know what fixes the problem or if the pяoblem remains

UTC/GMT is 14:16 on Sunday, January 06, 2013

Did this solve your problem?

Sorry this didn't help.

Question Info

Views: 5,217 Last updated: March 16, 2018 Applies to: